Bug 100615

Summary: Customer service Specfic changes
Product: Red Hat Network Reporter: Narsi Subramanian <narsis>
Component: RHN/Web SiteAssignee: Robin Norwood <robin.norwood>
Status: CLOSED CURRENTRELEASE QA Contact: Red Hat Satellite QA List <satellite-qa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: RHN DevelCC: dcurtis, rhn-bugs, smartin
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-08-05 19:54:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 101005    

Description Narsi Subramanian 2003-07-23 18:20:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
As discussed the following changes are required on the RHN site specific to
customer service. When folks send emails to customer service there is no
customer number or login information. Appreciate if either one or both is
included so CS can pull the entitlement information easily.

Secondly, the RHN payment page needs the following changes. This is
critical because we can start the customer without waiting for his/her
payment. Appreciate if both changes can be included in the next RHN push.


To purchase RHN entitlements, you may also mail a check or money order to us
using the following address...

*LOCKBOX*
Remittance Address:
Red Hat
PO Box 951701
Dallas, TX  75395-1701

If you are mailing in payment for your RHN Entitlement purchase, be sure to also
email your order details to rhn-payment@redhat.com.  Your email should include
your check number, the total amount of payment, type and quantity of
entitlement(s) desired, and the Red Hat Username you will be using to manage
your entitlements.  Failure to send an email containing this information may
result in a delay of your RHN Entitlement service activation.


-narsi.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.AS above.
2.
3.
    

Additional info:

Comment 1 Robin Norwood 2003-07-30 17:59:08 UTC
Both changes in CVS: The first request involved changing the message template to
include the user login, and oracle customer number (if any).

In the second request, '*LOCKBOX*' doesn't look right to me there, but I put it
in verbatim.  e-mail sent to narsis requesting confirmation.

Comment 2 Robin Norwood 2003-07-30 18:01:16 UTC
Testing notes:

The change also affects the message body for 'regular' feedback sent from
/help/contact.pxt, as the code is the same.

Doc notes:

The first change isn't customer-visable.  The second change is visible in the
reworded text at /network/sales/index.pxt

Comment 3 Josef Komenda 2003-08-04 14:11:12 UTC
User Login: jkomenda
User ID: 2011903
Customer Number: None

What is 'Customer Number' supposed to be?

Comment 4 Robin Norwood 2003-08-04 14:22:02 UTC
The oracle customer number - web_customer.oracle_customer_number in our schema.
 No idea what it's used for - our side of the codebase doesn't use it at all. 
Narsi asked for it, so I put it in....

Comment 5 Josef Komenda 2003-08-04 16:18:27 UTC
Ok, looks good in dev.

Comment 6 Josef Komenda 2003-08-04 21:39:52 UTC
Looks good in QA.

Comment 7 Josef Komenda 2003-08-05 19:54:03 UTC
Looks good in prod.