Bug 101571

Summary: The URL postgres://... is not supported by this version of GnuCash
Product: [Retired] Red Hat Linux Reporter: Greg Morgan <drkludge>
Component: gnucashAssignee: Bill Nottingham <notting>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://www.gnucash.org/lxr/gnucash/source/src/backend/postgres/README
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-08-06 16:00:43 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Greg Morgan 2003-08-04 06:56:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I followed the instructions in
http://www.gnucash.org/lxr/gnucash/source/src/backend/postgres/README. After
postgres was started and both a user and database were set up, I followed these
steps: from the README

How To Use This Thing
---------------------
a) Open your favorite datafile in the usual fashion.
b) Click on 'Save As'
c) enter the following URL instead of a filename in the file picker:
    postgres://localhost/some_dbname_you_pick

As soon as the ok button was pressed on the save as dialog box I received the
error message listed in the summary.  The full URL was postgres://localhost/myuser.



Version-Release number of selected component (if applicable):
gnucash-1.6.6-7

How reproducible:
Always

Steps to Reproduce:
1./etc/init.d/postgresql start
2.su - postgres
3.createuser myuser
4.createdb myuser
5.run gnucash
6.select file>new and follow the wizard selecting all accounts and press finish
7.select file>save as> postgres://localhost/myuser > press ok button
    

Actual Results:  Received the error message "The URL postgres://localhost/myuser
is not supported by this version of GnuCash"

Expected Results:  The title bar should change to "Accounts - GnuCash
(posgres://localhost/myuser)" and I could query the data with psql.

Additional info:

I also installed the SRPM file for gnucash.  the gnucash-1.6.spec file had
...
autoconf-2.13
%configure --enable-sql
# automake is fun.
make || :
cd src/engine
...

The --enable-sql is correct.  I compiled the SRPM with this and the application
worked as expected.  Is there any reason why this feature is not enabled?  I
would like this enabled in the next release of Red Hat, if possible.  It looks
like RH intended to enable this but didn't.  Is this a bug then?

Thanks,
Greg Morgan

Comment 1 Bill Nottingham 2003-08-04 14:55:51 UTC
Do you have gnucash-backend-postgres installed?

Comment 2 Greg Morgan 2003-08-05 08:25:47 UTC
I believe yes.  Since I wanted to use gnuCash with postgresql, I rpmed the
source package.  Next I configured/compiled gnuCash source with --enable-sql. 
So I have a working copy gnuCash with postgresql support.

Comment 3 Bill Nottingham 2003-08-05 14:49:08 UTC
Are you sure your rebuild went correctly, and it included the postgres backend
plugin?

Comment 4 Greg Morgan 2003-08-06 05:10:07 UTC
I am sure it worked.  I went into psql and queried the data from gnuCash.  

Let me back peddle here for a moment.  The default rpm that Red Hat shipped with
8.0 does not have the postgres backend.  What I am asking for is that Red Hat
would ship gnuCash with %configure --enable-sql.  Otherwise I have to compile it
that way.  The error message above is from the stock rpm not my compiled
version.  I am providing customer feedback as to how I would like to be able to
use gnuCash on RH.  If you don't use the postgres:// URL, then gnuCash uses the
normal XML backend and the postgres backend is inert.  I am not an RPM expert,
but it looks like the .spec file has the --enable-sql compile instruction, but
the binary shipped does not have the support.  This is what I tried to point out
in the Additional Information section of the original bug report.  I also tried
to show that I followed all the correct steps in setting up postgresSQL, etc.

Does this information clear up what I was driving at?


Comment 5 Bill Nottingham 2003-08-06 16:00:43 UTC
Yes, that clears it up.

The postgres backend is shipped in the gnucash that comes with Red Hat Linux 9
and later. :)

Comment 6 Greg Morgan 2003-08-07 06:33:05 UTC
Well I guess it is finally time to install version 9.  Thanks for already making
this feature available.