Bug 101628

Summary: ISDN, no default route after hangup or reboot
Product: [Retired] Red Hat Linux Beta Reporter: Uwe Beck <ubeck>
Component: redhat-config-networkAssignee: Harald Hoyer <harald>
Status: CLOSED CANTFIX QA Contact:
Severity: medium Docs Contact:
Priority: high    
Version: beta1   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-07-27 00:18:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 125273    

Description Uwe Beck 2003-08-04 21:02:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.08 [en] (X11; I; AIX 4.3)

Description of problem:
I create my provider by name "brickxmp".

/etc/sysconfig/network-scripts
ifcfg-eth0
ifcfg-eth1
fcfg-brickxmp <-- ifcfg-ippp0 before the new program version (see Bug 91607)

After the system was rebooted:

netstat -r
Kernel IP Routentabelle
Ziel            Router          Genmask         Flags   MSS Fenster irtt Iface
172.16.39.0     *               255.255.255.0   U         0 0          0 eth0
172.16.38.0     *               255.255.255.0   U         0 0          0 ippp0
172.16.37.0     *               255.255.255.0   U         0 0          0 eth1
169.254.0.0     *               255.255.0.0     U         0 0          0 eth1
127.0.0.0       *               255.0.0.0       U         0 0          0 lo
default         lex021          0.0.0.0         UG        0 0          0 eth0

The default route is set over eth0, but should be set over ippp0. Before this
version of redhat-config-network the ISDN-interface name was always ippp0.
This mistake comes from the loop in the if-up script and it was a random that
I have this mistake found because my providername is "brickxmp".

I see some effects if the name is ifcfg-brickxmp.

With /etc/sysconfig/network-scripts/ifcfg-brickxmp the kisdndock do not go
in the o.k. status (color gray) on the KDE desktop.
If I rename /etc/sysconfig/network-scripts/ifcfg-brickxmp in
/etc/sysconfig/network-scripts/ifcfg-ippp0 all works correct.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a provider with name begins with a-d
2. reboot
3.
    

Additional info:

See Bug 91607 in Red Hat 9

Comment 1 Harald Hoyer 2005-07-08 15:54:58 UTC
is this still an issue?

Comment 2 Uwe Beck 2005-09-08 19:16:51 UTC
Yes, this is still an issue.

Comment 4 Bill Nottingham 2007-07-27 00:18:27 UTC
Closing as CANTFIX.