Bug 10533

Summary: xlock gets killed and stops the locking; heavy swapping after long locking sessions
Product: [Retired] Red Hat Linux Reporter: Pekka Savola <pekkas>
Component: xlockmoreAssignee: Harald Hoyer <harald>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-03-28 14:56:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Pekka Savola 2000-04-03 05:07:02 UTC
xlockmore-4.14-1

1) If I xlock my Redhat 6.1 box, and leave it on for a long time and take
off the network connectivity (remove CAT5 cable for example), xlock seems
to break off from it locked state and return to UNLOCKED state!

This has bug has gotten me at least 4-5 times now.  I don't remember seeing
it in 6.0.  My xlocking sessions can be very long, up to a week or so
(generally 2-3 days).  I don't know for certain what causes this, but it
sure is annoying. :)

---
[psavola@myhost psavola]$ xlock
[ long time passes and network connectivity is lost ]
Access control list restored.
xlock: caught signal 11 while running flow mode (uid 154).
----

All I know that xlock WAS NOT killed manually.  When this happens, there
always has seemed to be a network connectivity loss involved (SSH):
----
Read from remote host otherdomain.fi: Connection reset by peer
Connection to otherdomain.fi closed.
----

2) After very long xlock sessions (over a couple of days), the computer
swaps for a very long time (1-2 minutes) and is unusable. I don't think
this should be so.  I don't remember seeing this in Redhat 6.0 either;
however I did use my computer more frequently back then.  This is P2-300
with 64 megs of RAM -- shouldn't be a problem.

I use Gnome.

Comment 1 Pekka Savola 2000-05-11 16:20:59 UTC
This seems to be fixed in xlockmore-4.15 that shipped with Redhat 6.2.

Comment 2 Pekka Savola 2000-05-15 22:33:59 UTC
Oops.  It seems xlockmore survived one potential crash, but didn't get over the
other.

The problem seems to persist. :-(

Comment 3 Bill Nottingham 2000-08-08 03:16:21 UTC
We've never been able to reproduce this.
Are you using a particular mode?

Comment 4 Pekka Savola 2000-08-08 05:52:39 UTC
I use the default modes (random, I think?).. just 'xlock'.

The swapping problem was resolved earlier, with an upgrade of xlock (to 6.2
version, I think).

RH6.2 version of xlockmore still lost its lock now and then.

I've been using Pinstripe version rebuilt on RH61 for a while, and I don't think
it has crashed yet.  I'll keep my eyes open.



Comment 5 Harald Hoyer 2001-03-28 14:16:19 UTC
Can this bug be closed????


Comment 6 Pekka Savola 2001-03-28 14:56:34 UTC
This is still a problem in 6.1, I guess, but I haven't seen this behaviour in
RHL7, so CURRENTRELEASE
is fine by me.