Bug 108973

Summary: installer dies on AMD KT600 even w/ nolapic noapic acpi=off
Product: [Fedora] Fedora Reporter: Joe Harrington <jhmail>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED NOTABUG QA Contact: Brian Brock <bbrock>
Severity: high Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: athlon   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-11-14 21:07:25 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Joe Harrington 2003-11-03 22:44:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:
The Fedora test3 install (and the installers for RH9/2.4.20 and Debian
3.0/2.4.18, and the HD installed version of the live-CD distro Morphix
0.4-1/2.4.21-xfs) crashes on an AMD mobo with Via KT600 chipset. 
Hangs/crashes for all these kernels vary in details, but none of the
following boot options, nor the complete set at once, fix the problem:

noapic nolapic acpi=off pci=noacpi nodma mem=nopentium

I have also turned APIC and the board's IDE off in the BIOS, and used
a Promise card for the IDE drives.

For the three Fedora tests done so fare, there were no error messages,
just "installer exited abnormally, rebooting", followed by shutdown
messages.  Once there was also:

spurious 8259A interrupt: IRQ7

...but this was not consistent in the other tests.

The RH9 install can fail several ways: the above, a series of oopses,
different each time (frequently involving mini-wm, kupdated, or
anaconda, or all three), a complete lockup hang, a progressive lockup
hang (i.e., the C-A-F2 prompt worked longer than the install screen
ran).  All hangs were at different parts of the install, generally in
the package loading.

I have replaced every hardware component except the motherboard
(actually, I traded that out too, and the nForce2 mobo had similar
problems, but I wasn't testing Fedora then).  I have tested the memory
overnight with memtest86, no errors.  I have put the disks on the mobo
IDE and on a Promise card.  It isn't hardware.

There are several discussions on linux-kernel and other mailing lists
about these crashes with late-model AMD chipsets, but I have tried all
the suggested solutions and none of them works.  I would test with 2.6
if I had install media that used it.  If someone can give me
instructions for how to make some, I would test it.

Version-Release number of selected component (if applicable):
kernel-2.4.22-1.2008.nptl

How reproducible:
Always

Steps to Reproduce:
1. download, check, and burn fedora CDs
2. attempt to install
3. it crashes, generally in package loading or prep to loading
    

Actual Results:  It crashes, generally in package loading or prep to
loading.  There are no consistent errors other than "installer exited
abnormally".  Because of the numerous other distros with similar
problems that are clearly kernel-related, I am logging this as a
kernel bug.

Expected Results:  No crash, the regular install.

Additional info:

Andrew de Quincy has patched ACPI (see their bugzilla, #845).  It
*may* fix this problem.  His description closely matches my system's
behavior.  However, that patch is against 2.6-test4.  Without a fix,
users with Via chipsets later than KT300 will not be able to install
Fedora.  I am frankly very surprised that this level of instability is
in the stable branch of the kernel.  I bought a new system in June and
I still cannot install any flavor of Linux.

--jh--

Comment 1 Joe Harrington 2003-11-14 21:07:25 UTC
This has turned out to be a problem with memory that tests as good
under 24 hours of memtest86 but doesn't keep up with Linux.

--jh--