Bug 110554

Summary: Websphere Application Server 5.0 is not working on AS 3.0
Product: Red Hat Enterprise Linux 3 Reporter: Spring Cho <nazilong22>
Component: IBMJava2-SDKAssignee: Karen Bennet <bennet>
Severity: high Docs Contact:
Priority: high    
Version: 3.0CC: bennet
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 19:00:06 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Spring Cho 2003-11-21 03:34:28 UTC
From Spring Cho:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:

I have been struggling with installing WAS 5.0 on Redhat Linux AS3.0

for a week. I read articles about incompatibility between IBM JDK

1.3.1 SR5 and Redhat AS3.0 in Redhat Bugzila, and I was experiencing

the same problem when I tried to install WAS 5.0 on AS 3.0.

I downloaded IBM JDK 1.6.1 SR6 from IBM website and I thought I 

succeed in installing WAS 5.0 on AS3.0. Installation steps looks 

fine and I see the first step applet. However, once I get out of the 

first step applet, I can't launch any WAS excution file. 

For example, all files under /opt/Websphere/AppServer/bin dont work

except serupCmdLine.sh file. The Strangist part is that all these 

shell scripts just literally hang when I run those. For instance, 

if I excute versionInfo.sh script, I see a java thread on "top"

command console and its cpu usage is around 50% and never decrease.

I dont see any error message or any warning message from either the 

console which I launch the script or log files. It seems to me that

the java thread just hangs and does something abviously, but since

I dont see any error or exception message from the thread, I have 

no idea what's going on. All other scripts are same. I tried to 

install WAS fix pack 2 cause I thought that maybe this was because

some WAS 5.0 containers are not stable, but I couldn't even launch

updateWizard.sh file in update package which I downloaded seperately

from IBM website. I get the same reaction from updateWizard.sh, which 

is no reaction.  I checked IBM JDK and java seems fine. This is such 

a headache because I dont see any error message. 

I assumed that WAS 5.0 may not work on AS3.0, but what about 

updateInstaller?  This is seperate package and if there is something 

wrong, at least I should get any message even if I dont understand

messages. Anyone secceed in installing WAS5.0 on AS3.0?

Any idea?

Version-Release number of selected component (if applicable):
2.4.21-4.ELsmp ; J2RE 1.3.1 IBM build cxia32131-20031021

How reproducible:

Steps to Reproduce:

1.Installed IBM JDK 1.3.1 SR6

2.Installed WAS 5.0 

3.At the end of the installation, I saw the first step applet.

4.Closed the first step applet.

5.Relaunch firstStep.sh or any files in ../bin or updateWizard.sh

Actual Results:  Jave thread just hangs. No error message, nothing

By checking "top", I see a jave thread consumes about 50% of cpu usage
constantly which never decrease until I kill the process.

I waited for more than 30 minutes and nothing happens unless I killed
the process.

Expected Results:  I should see an appropriate applet. At least, I
should see any error message if something is wrong. 

Additional info:

Comment 1 Karen Bennet 2003-11-21 03:54:25 UTC
There is a known problem with WebSphere 5.0 and RHEL3 which has been
reported as bz #101603.  This problem has been resolved with WebSphere
5.1; and Red Hat / IBM are investigating possible solutions for
WebSphere 5.0.

*** This bug has been marked as a duplicate of 101603 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:00:06 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.