Bug 111151

Summary: gtk+ should BuildRequires: glib-devel, XFree86-devel
Product: [Retired] Red Hat Raw Hide Reporter: Maxim Dziumanenko <dziumanenko>
Component: gtk+Assignee: Matthias Clasen <mclasen>
Status: CLOSED NEXTRELEASE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0Keywords: EasyFix
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-06-25 03:37:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Maxim Dziumanenko 2003-11-28 15:33:27 UTC
Description of problem:
1. glib headers and development libs needed to build gtk+, thus it
should BuildRequires: glib-devel (instead of glib)
2. X11 headers and development libs needed to build gtk+

Version-Release number of selected component (if applicable):
gtk+-1.2.10-28.1

How reproducible:
Always

Steps to Reproduce:
1.rpm -e glib-devel XFree86-devel
2.rpmbuild --rebuild gtk+-1.2.10-28.1.src.rpm
3.Wait for build errors
  
Actual results:


Expected results:


Additional info:

Comment 1 Miloslav Trmac 2003-11-28 16:15:44 UTC
Triage->Easyfix

Comment 2 Matthias Clasen 2004-06-25 03:20:34 UTC
*** Bug 124159 has been marked as a duplicate of this bug. ***