Bug 111163

Summary: libgsf-devel should Requires: glib2-devel, libxml2-devel, gnome-vfs2-devel
Product: [Fedora] Fedora Reporter: Maxim Dziumanenko <dziumanenko>
Component: libgsfAssignee: Jonathan Blandford <jrb>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: ddumas, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-04-11 20:56:42 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Maxim Dziumanenko 2003-11-28 17:24:41 UTC
Description of problem:
1. /usr/lib/pkgconfig/libgsf-1.pc (frpm libgsf-devel package)
references to glib2 and libxml2 pkgconfig files.
2. gsf-input-gnomevfs.h (frpm libgsf-devel package) includes headers
from gnome-vfs2-devel

Version-Release number of selected component (if applicable):
libgsf-1.8.2-1

How reproducible:
Always

Steps to Reproduce:
1.rpm -i libgsf-devel-1.8.2-1.i386.rpm
2.rpm -e gnome-vfs2-devel
3.rpmbuild --rebuild librsvg2-2.4.0-3.src.rpm (it requires
libgsf-devel, but doesn't directly depend on gnome-vfs2-devel)
4. Wait for build errors
  
Actual results:


Expected results:


Additional info:

Comment 1 Miloslav Trmac 2003-11-28 19:07:27 UTC
Triage->Easyfix

Comment 2 Warren Togami 2004-04-11 20:56:42 UTC
rawhide soon