Bug 112181

Summary: sendmail newaliases segmentation fault at boot
Product: [Fedora] Fedora Reporter: Kasper Dupont <bugzilla>
Component: sendmailAssignee: Thomas Woerner <twoerner>
Status: CLOSED WORKSFORME QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 1   
Target Milestone: ---   
Target Release: ---   
Hardware: i586   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-01-15 10:15:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Kasper Dupont 2003-12-15 19:41:52 UTC
Description of problem:
During boot a segmentation fault was reported from newaliases

Version-Release number of selected component (if applicable):
8.12.10-1.1.1

How reproducible:
Haven't been able to reproduce it.

Steps to Reproduce:
1. Boot
  
Actual results:
Starting sendmail: /etc/rc5.d/S80sendmail: line 116:   841
Segmentation fault
   /usr/bin/newaliases >/dev/null 2>&1
                                                           [  OK  ]

Expected results:
Starting sendmail:                                         [  OK  ]

Additional info:

Comment 1 Thomas Woerner 2004-01-15 10:15:39 UTC
I can not reproduce this.

Comment 2 Kasper Dupont 2004-03-05 09:13:41 UTC
I managed to get a core dump from a segfaulting newaliases command.

https://www.daimi.au.dk/~kasperd/newaliases/core

The core dump was produced by copying /usr/sbin/sendmail.sendmail to
/root/bin/newaliases, removing suid bit from the copy, and finaly
executing the command "while /root/bin/newaliases ; do true ; done".


Comment 3 Kasper Dupont 2004-03-20 13:58:24 UTC
This is a duplicate of bug #113830