Bug 112245

Summary: httpd still requires libdb-4.1.so?
Product: [Retired] Red Hat Raw Hide Reporter: Kaj J. Niemi <kajtzu>
Component: httpdAssignee: Joe Orton <jorton>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0CC: scier
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 2.0.48-4 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-01-02 13:59:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Kaj J. Niemi 2003-12-16 16:41:12 UTC
Description of problem:
There's something fishy with httpd-2.0.48, it's linked against both
bdb 4.1 and bdb 4.2 but requires only libdb-4.1.so?

% rpm -q --requires httpd-2.0.48-3|grep libdb
libdb-4.1.so

ldd `which httpd` |grep libdb
        libdb-4.1.so => /lib/libdb-4.1.so (0x0093d000)
        libdb-4.2.so => /lib/tls/libdb-4.2.so (0x003bc000)

Comment 1 Joe Orton 2004-01-02 13:59:41 UTC
The -4 rebuild got rid of the libdb-4.1 deps; you'll need the newer
apr-util too.

Comment 2 Joe Orton 2004-01-03 13:27:53 UTC
*** Bug 112817 has been marked as a duplicate of this bug. ***