Bug 1133962

Summary: [GSS] (6.3.z) Weld limitation in EAP integration code
Product: [JBoss] JBoss Enterprise Application Platform 6 Reporter: Shaun Appleton <sappleto>
Component: CDI/WeldAssignee: baranowb <bbaranow>
Status: CLOSED CURRENTRELEASE QA Contact: Matej Novotny <manovotn>
Severity: high Docs Contact:
Priority: unspecified    
Version: 6.3.2CC: bbaranow, istudens, jawilson, jharting, maschmid
Target Milestone: CR1   
Target Release: EAP 6.3.3   
Hardware: x86_64   
OS: Windows   
URL: https://c.na7.visual.force.com/apex/Case_View?id=500A000000LF54K
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1138192 (view as bug list) Environment:
Last Closed: 2019-08-19 12:42:09 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1138192    
Bug Blocks: 1151405    

Description Shaun Appleton 2014-08-26 14:34:13 UTC
There is a limitation [1] in EAP integration code when using Weld.

It seems that this optimization underestimates the problem with
package-private constructors. 

[1]
https://github.com/jbossas/jboss-eap/blob/6.x/weld/src/main/java/org/jboss/as/weld/services/bootstrap/ProxyServicesImpl.java#L68

Comment 11 Ron Šmeral 2015-01-16 17:56:41 UTC
Verified in 6.3.3.CP.CR1.