Bug 114274

Summary: garbled output with matroxfb and G400 dual head
Product: [Fedora] Fedora Reporter: Noa Resare <noa>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED UPSTREAM QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-06-15 10:25:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Noa Resare 2004-01-25 23:59:00 UTC
Description of problem:

When testing kernel-2.6.1-1.57 i tried to load the matrox framebuffer
but the console output was grabled no matter what resolution i tried
with fbset

Version-Release number of selected component (if applicable):
kernel-2.6.1-1.57 (i686 version)

How reproducible:
always

Steps to Reproduce:
1. boot said kernel into runlevel 3
2. log in as root
2. load the matroxfb module with '/sbin/modprobe i2c-matroxfb'

  
Actual results:

The visual output on the console becomes completely garbeled and
unreadable. I try with a couple of resolutions i know by running fbset
from a remote machine and while the video mode changes it always ends
up garbled and unreadable in some way.

Expected results:

At least some video modes should work with matroxfb

Additional info:

While I don't expect fixing a subsystem that is disabled per default
in fedora to be a priority I would like to suggest disabling matroxfb
in the kernel build until it is known to work.

If you do, I promise to file a feature request when matroxfb in 2.6.x
is fixed :)

Comment 1 Noa Resare 2004-01-26 00:00:54 UTC
Forgot to specify the hardware. /sbin/lspci gives the following
description: 

"Matrox Graphics, Inc. Millennium G400 MAX/Dual Head 32Mb"

Comment 2 Andreas Thienemann 2004-06-15 01:02:23 UTC
matroxfb is broken in the current kernel series.

for kernel-2.6.6-1.427 applying the patch from
http://ftp.cvut.cz/matroxfb/matrox-2.6.7-rc2-c1818.gz fixes the issue.

With this patch applied matroxfb works for me with a G400.

Thus, I'd like to see redhat apply that patch to their kernel-tree.

Comment 3 Dave Jones 2004-06-15 10:25:24 UTC
a quicker path is to push Petr to push his changes upstream.
if there's a reason he hasn't done so already, there's possibly a
reason we shouldn't take this either.