Bug 114498

Summary: The window lists's OMF file is not proper UTF-8
Product: [Retired] Red Hat Raw Hide Reporter: Gary Peck <gbpeck>
Component: gnome-panelAssignee: Mark McLoughlin <markmc>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: low Docs Contact:
Priority: low    
Version: 1.0CC: alan, aleksey, aoliva, gczarcinski, ikoframe, jik, jturner, mikem
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-02-29 07:22:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Gary Peck 2004-01-28 19:32:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20040105 Firebird/0.7

Description of problem:
The /usr/share/omf/gnome-panel/window-list-es.omf is not properly
encoded. This causes rpm updates to emit the following warning:

/usr/share/omf/gnome-panel/window-list-es.omf:12: parser error : Input
is not proper UTF-8, indicate encoding !
      Manual de la miniaplicaic&#65533;n Lista de ventanas V2.6
                               ^
/usr/share/omf/gnome-panel/window-list-es.omf:12: error: Bytes: 0xF3
0x6E 0x20 0x4C
      Manual de la miniaplicaic&#65533;n Lista de ventanas V2.6
                               ^
OMF file does not exist, is not readable, or is not well-formed XML:
/usr/share/omf/gnome-panel/window-list-es.omf
Unable to complete update.  Could not register
/usr/share/omf/gnome-panel/window-list-es.omf


Version-Release number of selected component (if applicable):
gnome-panel-2.5.3.1-2

How reproducible:
Always

Steps to Reproduce:
1. install gnome-panel
2. run scrollkeeper-update
3.
    

Actual Results:  The same output as in the description.

Additional info:

Comment 1 Gary Peck 2004-02-06 04:56:39 UTC
Looks like it's fixed upstream according to
http://www.redhat.com/archives/fedora-devel-list/2004-February/msg00259.html.

Comment 2 Mike McLean 2004-02-12 18:29:05 UTC
*** Bug 114547 has been marked as a duplicate of this bug. ***

Comment 3 Mike McLean 2004-02-12 18:30:03 UTC
*** Bug 114898 has been marked as a duplicate of this bug. ***

Comment 4 Bill Nottingham 2004-02-18 17:34:23 UTC
*** Bug 116143 has been marked as a duplicate of this bug. ***

Comment 5 Bill Nottingham 2004-02-18 17:34:53 UTC
*** Bug 115746 has been marked as a duplicate of this bug. ***

Comment 6 Leonard den Ottolander 2004-02-23 10:12:33 UTC
According to bug 116475 this issue is still open in gnome-panel-2.5.3,
in contrast to what comment 1 suggests.


Comment 7 Bill Nottingham 2004-02-23 23:16:06 UTC
*** Bug 116475 has been marked as a duplicate of this bug. ***

Comment 8 Mike McLean 2004-02-23 23:18:34 UTC
It's very nice that this bug is fixed upstream, but can we please
actually get that fix in rawhide?

Comment 9 Bill Nottingham 2004-02-23 23:50:36 UTC
*** Bug 116631 has been marked as a duplicate of this bug. ***

Comment 10 Leonard den Ottolander 2004-02-24 10:10:23 UTC
Does the update to gnome-panel-2.4.2-1 solve this issue? If so it
needs to be propagated to 2.5.3 (upstream) (see bug 116475 for FC2 test1).


Comment 11 Bill Nottingham 2004-02-24 20:26:17 UTC
*** Bug 116691 has been marked as a duplicate of this bug. ***

Comment 12 Mark McLoughlin 2004-02-27 17:57:45 UTC
*** Bug 114667 has been marked as a duplicate of this bug. ***

Comment 13 Mark McLoughlin 2004-02-27 22:53:43 UTC
Should be fixed in Raw Hide now

Comment 14 Alexandre Oliva 2004-02-28 18:45:07 UTC
Err...  You call that a fix?  It was a very ugly work around!  What's
wrong with the correct fix proposed in bug 116691?  Perhaps the fact
that `aplicación', which I wrote in the bugzilla bug entry form,
didn't make it to the actual bug report correctly?

Comment 15 Mark McLoughlin 2004-02-29 07:22:23 UTC
This was fixed upstream. All I did was pull the latest upstream
tarball. If you think the upstream fix was wrong please reopen:

http://bugzilla.gnome.org/show_bug.cgi?id=132715

Comment 16 Alexandre Oliva 2004-02-29 21:36:32 UTC
Oh, my, sorry about my tone above.  It was meant to be read in a
joking tone, but only now I realize I missed :-)s all over.  If you
got me all wrong, please accept my deepest apologies.  I added a note
to the upstream bug, but I don't have permission to reopen it.  I hope
it doesn't get lost.

Comment 17 Mark McLoughlin 2004-02-29 21:42:51 UTC
Heh - don't worry, I've learned well enough at this stage not to take
stuff personally :-)