Bug 115566

Summary: NIC drivers not working with SMP kernel
Product: [Fedora] Fedora Reporter: Gene Czarcinski <gczarcinski>
Component: kernelAssignee: Jeff Garzik <jgarzik>
Status: CLOSED NOTABUG QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: high    
Version: rawhideCC: peterm
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-02-27 14:56:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Gene Czarcinski 2004-02-13 16:07:31 UTC
Description of problem:

Using a Linksys NC100 10/100 NIC.  This works fine with RHL9 and FC1.
 Although it works well enough to do an nfs install, I cannot get it
to see other systems under FC2 test1.

I installed FC2 test1 on another system with a 3C940 NIC.  This was
not recognized by the installer and I had to do a harddisk install but
once installed, I was able to configure the network and have it work.

Comment 1 Gene Czarcinski 2004-02-14 19:35:00 UTC
I noticed that I am getting in /var/log/messages:

eth0 transmit timed out, status fc67c057 CSR12 00000000, resetting ...

Comment 2 Gene Czarcinski 2004-02-15 00:21:21 UTC
I swear this system must be on the RSL (random screw list) por even
the NSRSL (not so random screw list)!  This is driving me nuts.

OK, two successful NFS installs to Opteron 140 with 3C940 NIC and
laptop with e100 NIC.  Plus I have the kickstart file from the
successful NFS install on the system that cannot communicate now.

I tried to do another NFS install ... this time it hung.

OK, maybe it is the Linksys NC100 NIC ... change to another ... nope,
still broken.

OK, maybe it is the tulip driver.  Get out a Netgear GA311 (R8169
driver).  Make sure it works with FC1 and Win2k ... works fine.  Now
try to do an NFS install ... hangs.  OK, do a harddisk install (had to
do that on the Operon because of the 3C940) and then configure it post
install.  Nope, still broken

Change the cable ... nope.  Change the interface on the Netgear switch
... nope.  Move the connection to a separate Netgear switch ... nope.


Comment 3 Gene Czarcinski 2004-02-15 16:58:43 UTC

I got things to work ... with the UP kernel.  Same hardware, etc. but
booted up the UP kernel and the NICs worked!

The other systems that worked were both UP systems.

Comment 4 Gene Czarcinski 2004-02-15 18:29:50 UTC
Another data point:  a dual athlon 2800+ with an Intel Ethernet Pro 100 
(8086:1229) and the e100 driver WORKS with the smp kernel!  So it is
not just smp.

Comment 5 Gene Czarcinski 2004-02-15 20:06:13 UTC
Still the same with the latest kernel: 2.6.2-1.81

Comment 6 Gene Czarcinski 2004-02-19 17:28:46 UTC
Still not working with smp kernel 2.6.3-1.91

Comment 7 Gene Czarcinski 2004-02-21 19:01:43 UTC
Still not working with smp kernel 2.6.3-1.96

Comment 8 Sammy 2004-02-22 16:16:57 UTC
This seems to be duplicate of 115877. 

Comment 9 Gene Czarcinski 2004-02-22 20:14:00 UTC
Right now the MOBO that has the problem has been "smoked" and I do not
know it the replace will have the same problem until I get it and try.
 The report may lapse because I do not have a system to duplicate the

Comment 10 Gene Czarcinski 2004-02-26 23:45:46 UTC
OK, networking (the NICs) is now working with the 2.6.3-1.109 smp
kernel ... original NC100.  I have also replace the motherboard  ---
it is now a Gigabyte 6VTXD rather than an Abit VP6.

I will try the old kernels to see if they work or not.  If they do not
then it looks like some software got fixed.  If they do then it looks
like the problem was hardware (the motherboard) which ended up getting

Comment 11 Gene Czarcinski 2004-02-27 14:56:17 UTC
I just reinstalled FC2 test1 snapshot and the NC100 NIC is working
fine with the smp kernel.  Conclusion:  motherboard (hardware) bad ...
getting it "smoked" was not a bad thing afterall.  Everything works
with the new motherboard.