Bug 120776

Summary: ImageMagick should require autoconf >= 2.58 and automake >= 1.7 to avoid rebuilding problems
Product: [Fedora] Fedora Reporter: Robert Scheck <redhat-bugzilla>
Component: ImageMagickAssignee: Jonathan Blandford <jrb>
Status: CLOSED RAWHIDE QA Contact: Mike McLean <mikem>
Severity: low Docs Contact:
Priority: medium    
Version: rawhideCC: ddumas
Target Milestone: ---Keywords: EasyFix
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-10-11 09:58:44 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 123268    
Description Flags
Allows to build ImageMagick 5.5.7 with automake >= 1.6 and autoconf >= 2.57 none

Description Robert Scheck 2004-04-13 16:38:55 EDT
Description of problem:
If I use automake = 1.6 and autoconf = 2.57 to rebuild 
ImageMagick, the rebuilding dies at the end with not found files 
(the .so extension is missing at all "so"-files in %{_libdir}).

Version-Release number of selected component (if applicable):

How reproducible & Steps to Reproduce:
Every time, see above.
Actual results:
I my eyes, there are two possibilities:

- require automake > 1.6 (that means automake17 or automake >= 1.8) 
  and autoconf > 2.57 (automake >= 2.58)


- require automake >= 1.6 and autoconf >= 2.57, but add the patch
  (it's a modified patch 7)

Expected results:
One of the both suggest solutions or a better one.
Comment 1 Robert Scheck 2004-04-13 16:39:43 EDT
Created attachment 99381 [details]
Allows to build ImageMagick 5.5.7 with automake >= 1.6 and autoconf >= 2.57
Comment 2 Robert Scheck 2004-08-23 12:40:45 EDT
Okay, now autoconf 2.59 and automake 1.9.1 are the current versions, 
so I think, the build requirements should be fixed instead of some 
patch merging, I'm expecting now:

BuildRequires: automake >= 1.7 autoconf >= 2.58 libtool >= 1.5

To avoid rebuilding problems, this build requirements should set in 
the spec file. Marking this bug with priority low and as EasyFix.
Comment 3 Tim Waugh 2004-10-11 09:58:44 EDT
Fix built as