Bug 12144

Summary: Graphical boot screen kills bios POST
Product: [Retired] Red Hat Linux Reporter: Hans de Goede <hdegoede>
Component: liloAssignee: Michael K. Johnson <johnsonm>
Status: CLOSED DEFERRED QA Contact:
Severity: medium Docs Contact:
Priority: low    
Version: 7.1Keywords: FutureFeature
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: Florence Gold
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-02-19 10:36:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Hans de Goede 2000-06-12 18:43:40 UTC
The graphical boot screen kills the bios POST screen, even if exited with
CTRL-X, the bios POST screen is an important diagnostic tool for new
hardware installs, and hence this is a mis feature. Although I would prefer
the grapihcal screen to go away entirely. I think that making a copy of the
text screen before throwing up the graphical screen and restoring this when
CTRL-X is pressed is a must, this is AFAIK, also what win9x does when you
press ESC.

Comment 1 Hans de Goede 2000-07-01 08:06:38 UTC
Just adding a comment to get a mail of this for my archive (mailing was broken
at the time I entered this)


Comment 2 Glen Foster 2001-01-11 21:06:09 UTC
This defect is considered MUST-FIX for Florence Gold release

Comment 3 Nalin Dahyabhai 2001-02-15 06:02:53 UTC
Removing the "messages" directive from /etc/lilo.conf and reinstalling lilo (by
running "/sbin/lilo") will cause LILO to use only the older text-only interface.

Comment 4 Hans de Goede 2001-02-15 08:33:22 UTC
I know,

Thats not the point, what if I never get into linux because of a bios setup
error, which I can't see because my boot screen is gone?

Come on how hard can it be to just save the VGAcards textbuffer before showing
the pretty screen, and restoring it when someone switches back to textmode.


Comment 5 Hans de Goede 2001-02-19 10:36:09 UTC
I've thought a bit about this, and this is not an acceptable solution to me,
thus I'm changing the to resolved -> deferred and setting the priority low, and
the sevirty to enhancement.