Bug 123504

Summary: scrollback doesn't work with screen in xterm/any other x11-based terminal
Product: [Fedora] Fedora Reporter: Antti Hartikainen <ankka+bugs>
Component: screenAssignee: Daniel Reed <djr>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 2CC: faisy, florian.laroche, redhat-bugzilla
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-05-19 13:34:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Antti Hartikainen 2004-05-18 21:36:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
If running screen inside x11-based terminal, nothing gets from screen
to terminals backscroll buffer.

I can't really explain this but here's how to reproduce:

Try 1:
1) run xterm/kterm/wterm/rxvt with scrollbuffer
2) run screen
3) run something that produces many lines of text (ps, ls)
4) nothing gets to terminals scroll buffer (terminals sidebar doesn't
grow or shift-pgup/pgdn doesn't work)

Try 2:
Same without running screen: works perfectly.

Try 3:
1) run xterm/any other terminal
2) run ps for example <-- this is added to scroll buffer.
3) run screen
4) run ls for example <-- this is not added to scroll buffer.
5) so now scrolling buffer up will print output of 'ps' that was run
earlier, not ls as it should.

Try 4:
1) now in console, without X. Login.
2) run screen
3) run ls or something that produces many lines
4) scrolling up/down with shift-pgup/pgdn works fine.

With FC1 everything worked fine.

I'm not sure if this is screen related, i've tried to downgrade
following packages back to fc1: screen, bash, termcap, libtermcap with
no results.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
described in description.

Actual Results:  I didn't see anything in scroll buffer :)

Expected Results:  I should have seen scroll buffer :)

Additional info:

Explained in description.

Comment 1 Antti Hartikainen 2004-05-19 13:34:20 UTC
Seems this is screen feature, not a bug, closing.

Uncommenting these lines in screenrc was the solution.

# Do not use xterms alternate window buffer.
# This one would not add lines to the scrollback buffer. 
#termcap xterm|xterms|xs ti=\E7\E[?47l
#terminfo xterm|xterms|xs ti=\E7\E[?47l

Comment 2 Miroslav Lichvar 2009-09-25 12:42:23 UTC
*** Bug 492729 has been marked as a duplicate of this bug. ***

Comment 3 Miroslav Lichvar 2011-02-04 15:44:18 UTC
*** Bug 646909 has been marked as a duplicate of this bug. ***