Bug 127846

Summary: .openoffice/user/work link to ~ deletes files at installation
Product: [Fedora] Fedora Reporter: Bertil Askelid <bertil>
Component: openoffice.orgAssignee: Dan Williams <dcbw>
Status: CLOSED RAWHIDE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 2CC: alexandra.kossovsky
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-09-25 19:41:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Bertil Askelid 2004-07-14 17:30:20 UTC
Description of problem:

Standard installation of OpenOffice comes with a soft link
~/.openoffice/user/work that links to ~

At installation OpenOffice cleans up old installations and deletes
superfluous and old files. Unfortunately, it also traverses the "work"
link at this, causing MAJOR DISTURBANCE to my file system.

It took me quite some time wondering what was going on and then
restoring my home directory from my backups!

Is this a virus or what ?

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1. install OpenOffice
2.
3.
  
Actual results:

Deletions of random files in home directory -- lots of them

Expected results:

DON'T TOUCH MY FILES !!!!!!

Additional info:

Comment 1 Dan Williams 2004-07-14 17:41:47 UTC
This link hasn't been created in the installation since before FC2,
but if you upgraded continuously, it will have been there.  Out of
curiosity, it shouldn't be launching the installer, except to
"upgrade" if you went from 1.0.x -> 1.1.x, so it should never ask to
delete user files.  Can you paste the contents of your ~/.sversionrc
file here?

Comment 2 Bertil Askelid 2004-07-14 19:07:59 UTC
~/.sversionrc

[Versions]
OpenOffice.org 1.1.1=file:///home/bertil/.rhopenoffice1.1

May I suggest that you don't follow links outside the ~/.openoffice
directory when you clean up. That's way too risky!

Comment 3 Dan Williams 2004-09-17 15:09:07 UTC
*** Bug 130973 has been marked as a duplicate of this bug. ***

Comment 4 Dan Williams 2004-09-25 19:41:04 UTC
Please test with the openoffice.org-1.1.2-5 RPMs in Rawhide, it should
be fixed in that version.  If the problem persists with that version,
please reopen this bug.  Thanks!