Bug 130190

Summary: No kernel-doc update needed
Product: [Fedora] Fedora Reporter: David Masterson <davidm_95123>
Component: rhn-appletAssignee: Bret McMillan <bretm>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 2CC: mattdm
Target Milestone: ---   
Target Release: ---   
Hardware: athlon   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-06-30 02:53:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description David Masterson 2004-08-17 20:27:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
The RHN-Applet constantly shows a red exclamation and claims that I
need an update to "kernel-doc".  It shows between 1 and 5 newer
versions of "kernel-doc" that I could apply (from 2.6.6 and 2.6.7). 
However, once I run up2date, it reports that my system is up to date
and no new packages are needed.  I've tried removing the "kernel-doc"
entries from ~/.rhn-applet/updates-released (across all "~"), but it
just seems to come back anyway.  Where is this coming from?

Version-Release number of selected component (if applicable):
2.1.7-1.1

How reproducible:
Always

Steps to Reproduce:
1. RHN-Applet turns into a red exclamation.
2. Click on RHN-Applet and note the list of updates.
3. Bring up Up2Date and see if it reports "no updates needed".
    

Actual Results:  Up2Date reports "no updates needed" while RHN-Applet
reports that "kernel-doc" needs an update.

Expected Results:  Either up2date should update the system or inform
rhn-applet that no updates are needed.

Additional info:

More information is needed on how to configure and control RHN-Applet
and it's connection to up2date (or yum).  There should be HELP dialogs
and CONFIG buttons.

Comment 1 David Masterson 2004-08-17 20:31:56 UTC
Looking at it now, I'm not sure the description says exactly what I
wanted.  RHN-Applet shows a red exclamation point and between 1 and 5
newer versions of "kernel-doc" (ie. one line with up to 5 available
updates).  Up2Date, however, reports that my system is up-to-date.  I
do not see any clean way of fixing this (as in the updates-released file).

Comment 2 Matthew Miller 2005-04-26 15:34:58 UTC
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.

Comment 3 David Lawrence 2006-04-18 20:16:21 UTC
NEEDINFO_ENG has been deprecated in favor of NEEDINFO or ASSIGNED. Changing
status to ASSIGNED for ENG review.

Comment 4 Matthew Miller 2006-06-30 02:53:46 UTC
Looking through old bugs. FC2 no longer gets updates through rhn, since it's
maintained by Fedora Legacy. Plus, the whole rhn-applet thing was horribly prone
to this sort of thing and is being replaced in FC6. So, marking WONTFIX.