Bug 133349

Summary: RPM 4.2.3 installed by Upgrading to Taroon Update 3 will not allow me to use -qip to provide all the details of an uninstalled package
Product: Red Hat Enterprise Linux 3 Reporter: Mark Pawson <mark.pawson>
Component: rpmAssignee: Jeff Johnson <jbj>
Status: CLOSED WORKSFORME QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 3.0CC: pnasrat
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-09-27 13:57:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Mark Pawson 2004-09-23 13:00:11 UTC
Description of problem:

As the summary

Version-Release number of selected component (if applicable):
 4.2.3

How reproducible:
100%

Steps to Reproduce:
1.Copy an RPM to the current dir.
2.type rpm -qip <PACKAGE_NAME.RPM>
3.inspect the error message!
  
Actual results:


Expected results:
I would like to be greeted with full details of the package i.e. its
name, version, description etc.

Additional info:
This command works with all the versions of rpm on the other servers
e.g. 3.0.5 etc.

Comment 1 Jeff Johnson 2004-09-23 22:16:51 UTC
What is the error message please?

Comment 2 Mark Pawson 2004-09-27 08:14:19 UTC
Sorry,

The error message is:

-qip: unknown option

This appears when I run : rpm -qip racvnc-1.0-1.i386.rpm  from the
command line.

Thanks


Comment 3 Jeff Johnson 2004-09-27 11:40:08 UTC
What does the following say?
    rpm -qp racvnc-1.0-1.i386.rpm

Try also
     rpm -qi -p racvnc-1.0-1.i386.rpm

Does that work on your system?

Comment 4 Mark Pawson 2004-09-27 12:30:58 UTC
Hello Jeff,

I have tried rpm -qp racvnc-1.0-1.i386.rpm it produces the following:

racvnc-1.0-1

I also tried rpm -qi -p racvnc-1.0-1.i386.rpm it produced:

-qi: unknown option

Thanks




Comment 5 Jeff Johnson 2004-09-27 12:41:32 UTC
-qi unknown option not found means that /usr/lib/rpm/rpmpopt*
is not being found.

What does rpm -V rpm say?



Comment 6 Mark Pawson 2004-09-27 13:13:04 UTC
Jeff,

It says:

package rpm is not installed

I have run rpm -i rpm-4.2.1-4.4 which does not work because it
complains of a missing "popt = 1.8.1 is needed by rpm-4.2.1-4.4" thus
I ran: 

rpm -q popt which said:
popt-1.8.2-10

This I find most confusing, but it is probably beyond the scope of
this bug, which appears to be a missing installation of rpm.  FYI I
installed RHEL 3 Taroon Update 3 and have since updated it fully using
RHN.  There appear to be a few problems with package conflicts where
the package is already installed but rpm is asking for an older
version, just like the description above.  I imagine you'll be closing
this bug?

Thanks

Comment 7 Jeff Johnson 2004-09-27 13:57:17 UTC
Hmm, dunno what happened.

Reinstalling rpm-4.2.3-10 from RHEL3U3 (all the packages, including
popt) should fix the problem.

Reopen this bug if you need more.