Bug 1335414

Summary: Graphical upgrade failed with error with no details
Product: [Fedora] Fedora Reporter: Kamil Páral <kparal>
Component: gnome-softwareAssignee: Kalev Lember <klember>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 23CC: alejandronova, ffranz, juliux.pigface, klember, mcatanzaro, pnemade, rhughes, sanjay.ankur, skala.rock
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: gnome-software-3.20.3-1.fc24 gnome-software-3.20.4-1.fc23 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-07-20 23:49:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1308538    
Attachments:
Description Flags
error screenshot (show details toggled on)
none
packagekit output from journal
none
pkmon output during that error none

Description Kamil Páral 2016-05-12 08:30:18 UTC
Description of problem:
I tried following https://fedoraproject.org/wiki/QA:Testcase_Workstation_Graphical_Upgrade to test graphical upgrades. I was downloading new packages for some time, and then I received an error message "Sorry this did not work. Installation of Fedora failed." with no details (the expander does not show anything when toggled).

I don't see anything in logs either.

Version-Release number of selected component (if applicable):
gnome-software-3.20.3-0.191.20160425git.fc23.x86_64
libhif-0.2.3-0.145.20160427git.fc23.x86_64
libappstream-glib-0.5.14-1.fc23.x86_64
json-glib-1.2.0-1.fc23.x86_64
PackageKit-1.1.1-1.fc23.x86_64


How reproducible:
don't know, happened on my first run

Steps to Reproduce:
no idea

Comment 1 Kamil Páral 2016-05-12 08:30:58 UTC
Created attachment 1156499 [details]
error screenshot (show details toggled on)

Comment 2 Kamil Páral 2016-05-12 08:31:15 UTC
Created attachment 1156500 [details]
packagekit output from journal

Comment 3 Kamil Páral 2016-05-12 08:31:23 UTC
Created attachment 1156501 [details]
pkmon output during that error

Comment 4 Kamil Páral 2016-05-12 08:34:09 UTC
When I click on Download again in gnome-software, it seems to continue downloading (resuming where it stopped last time).

Comment 5 Kamil Páral 2016-05-12 09:05:51 UTC
During the same run, this happened again several times(!!), same behavior. There's usually some delay between the last "downloading" and "finished" line in pkmon and seeing the error pop up. So this seems related to some network timeout.

According to pkmon, the downloading is resumed correctly, however the progress bar is off, it jumps to about 10% on resume, and then fills up very quickly. It seems that the progress bar now shows the download progress of the *remaining* packages, not of the full process (so e.g. if 10% of packages remained to be downloaded, after resume the progress bar shows progress of those 10% of packages, and fills up 10x quicker than originally).

Comment 6 Richard Hughes 2016-05-12 09:38:17 UTC
(In reply to Kamil Páral from comment #5)
> It seems that the progress bar now shows the download progress of
> the *remaining* packages, not of the full process (so e.g. if 10% of
> packages remained to be downloaded, after resume the progress bar shows
> progress of those 10% of packages, and fills up 10x quicker than originally).

Is that not correct? It seems odd to jump to 50% at startup.

Comment 7 Kamil Páral 2016-05-12 12:44:11 UTC
(In reply to Richard Hughes from comment #6)
> Is that not correct? It seems odd to jump to 50% at startup.

Imagine that the progress bar is at 50% and then the error dialog appears. After you press "Install" again, the progress bar goes to 10%. What are you going to assume? I'd assume that the whole process starts from scratch (i.e. re-downloading all the packages, even the ones already downloaded), and be annoyed by it. 

However, this is definitely less important than the fact that it fails during download, and that it does not communicate any reasonable reason for that error :)

Comment 8 Kamil Páral 2016-05-12 13:27:43 UTC
I have tried another upgrade, and again I received this same "no reason" error several times. Seems to be reproducible, at least right now in my current location.

Comment 9 Ernesto Manríquez 2016-05-16 10:14:10 UTC
I can reproduce this. After 2, 3 minutes, my Internet connection stops downloading packages and, after a while, I see this error, so, this is related to a network timeout.

Comment 10 Parag Nemade 2016-05-16 14:21:12 UTC
Yes I too have found this bug. I restarted this upgrade twice and then it got completed. I am not sure if this happened because of slow network but I remember seeing logs from first run showing timeout for connection.

Comment 11 Dominik Skaličan 2016-05-16 19:55:51 UTC
I can confirm it. Few minutes, after the download was triggered (point 6 in https://fedoraproject.org/wiki/QA:Testcase_Workstation_Graphical_Upgrade) pop-up window appeared without error message. Retried the all the steps several time with the same outcome.

Comment 12 Dominik Skaličan 2016-05-16 20:01:17 UTC
(In reply to Dominik Skaličan from comment #11)
> I can confirm it. Few minutes, after the download was triggered (point 6 in
> https://fedoraproject.org/wiki/QA:Testcase_Workstation_Graphical_Upgrade)
> pop-up window appeared without error message. Retried the all the steps
> several time with the same outcome.

point 9*

Comment 13 Michael Catanzaro 2016-05-16 20:37:30 UTC
FWIW: This happened to me because I forgot to reboot and was still running PackageKit from F23 rather than the copr when I tried to start the upgrade. In my case, the error occurred when clicking the Download button rather than after updates were already being downloaded, hence I think this is a separate issue -- I'm just mentioning it here because the error message I saw was identical.

Comment 14 Giulio 'juliuxpigface' 2016-05-16 20:40:29 UTC
I hit this here.

My network has been unreachable for some seconds. The upgrade could obviously not continue, but a more clear and verbose message may be useful.

Comment 15 Fabiano Franz 2016-05-18 16:00:05 UTC
Same here. I tried to continue after the message by closing and reopening Software, it reported to continue the download. By the end I hit 'Install', it restarted and stayed in the installing packages screen for about 3 hours, when I gave up and Ctrl+Alt+Del back to F23.

Comment 16 Kamil Páral 2016-05-19 06:28:05 UTC
(In reply to Fabiano Franz from comment #15)
> By the end I hit 'Install',
> it restarted and stayed in the installing packages screen for about 3 hours,
> when I gave up and Ctrl+Alt+Del back to F23.

Fabiano, this will be a different bug. Could please report it separately and attach journal logs from the upgrade process?

Comment 18 Fedora Update System 2016-05-28 18:37:50 UTC
gnome-software-3.20.3-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2be09c9861

Comment 19 Fedora Update System 2016-05-29 23:26:10 UTC
gnome-software-3.20.3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2be09c9861

Comment 20 Fedora Update System 2016-05-30 21:18:35 UTC
gnome-software-3.20.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Kamil Páral 2016-05-31 11:03:16 UTC
I tested this with the following builds:
http://koji.fedoraproject.org/koji/buildinfo?buildID=768991
http://koji.fedoraproject.org/koji/buildinfo?buildID=762450
http://koji.fedoraproject.org/koji/buildinfo?buildID=768995
http://koji.fedoraproject.org/koji/buildinfo?buildID=769263
http://koji.fedoraproject.org/koji/buildinfo?buildID=762454
http://koji.fedoraproject.org/koji/buildinfo?buildID=762449

I can now see the error message (under the details section), it says:

"
Detailed errors from the package manager follow:

cannot download Packages/r/rest-0.8.0-1.fc24.x86_64.rpm to /var/cache/PackageKit/24/metadata/fedora/packages/: Curl error (28): Timeout was reached for https://mirrors.fedoraproject.org/metalink?repo=fedora-24&arch=x86_64 [Operation too slow. Less than 1000 bytes/sec transferred the last 120 seconds]
"

So, this particular problem is fixed (error details displayed). We will still want to have this fixed in F23, so reopening. I'll report a separate bug about the inability to cope with network timeouts.

Comment 22 Fedora Update System 2016-06-03 09:34:25 UTC
PackageKit-1.1.1-2.fc23 appstream-data-23-11.fc23 fwupd-0.7.1-1.fc23 gnome-software-3.20.3-1.fc23.1 json-glib-1.2.0-1.fc23 libappstream-glib-0.5.14-1.fc23 libgusb-0.2.9-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fad11727bf

Comment 23 Fedora Update System 2016-06-05 03:58:56 UTC
PackageKit-1.1.1-2.fc23, appstream-data-23-11.fc23, fwupd-0.7.1-1.fc23, gnome-software-3.20.3-1.fc23.1, json-glib-1.2.0-1.fc23, libappstream-glib-0.5.14-1.fc23, libgusb-0.2.9-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fad11727bf

Comment 24 Kamil Páral 2016-06-06 13:47:14 UTC
(In reply to Fedora Update System from comment #23)
> PackageKit-1.1.1-2.fc23, appstream-data-23-11.fc23, fwupd-0.7.1-1.fc23,
> gnome-software-3.20.3-1.fc23.1, json-glib-1.2.0-1.fc23,
> libappstream-glib-0.5.14-1.fc23, libgusb-0.2.9-1.fc23 has been pushed to the
> Fedora 23 testing repository. If problems still persist, please make note of
> it in this bug report.

Verified fixed with this.

Comment 25 Fedora Update System 2016-07-12 19:14:10 UTC
PackageKit-1.1.2-1.fc23 appstream-data-23-11.fc23 fwupd-0.7.2-1.fc23 gnome-shell-3.18.5-2.fc23 gnome-software-3.20.4-1.fc23 json-glib-1.2.0-1.fc23 libappstream-glib-0.5.16-2.fc23 libgusb-0.2.9-1.fc23 libhif-0.2.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fad11727bf

Comment 26 Fedora Update System 2016-07-14 01:24:56 UTC
PackageKit-1.1.2-1.fc23, appstream-data-23-11.fc23, fwupd-0.7.2-1.fc23, gnome-shell-3.18.5-2.fc23, gnome-software-3.20.4-1.fc23, json-glib-1.2.0-1.fc23, libappstream-glib-0.5.16-2.fc23, libgusb-0.2.9-1.fc23, libhif-0.2.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fad11727bf

Comment 27 Fedora Update System 2016-07-14 13:27:44 UTC
PackageKit-1.1.3-1.fc23 appstream-data-23-11.fc23 fwupd-0.7.2-2.fc23 gnome-shell-3.18.5-2.fc23 gnome-software-3.20.4-1.fc23 json-glib-1.2.0-1.fc23 libappstream-glib-0.5.16-2.fc23 libgusb-0.2.9-1.fc23 libhif-0.2.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fad11727bf

Comment 28 Fedora Update System 2016-07-15 17:52:25 UTC
PackageKit-1.1.3-1.fc23, appstream-data-23-11.fc23, fwupd-0.7.2-2.fc23, gnome-shell-3.18.5-2.fc23, gnome-software-3.20.4-1.fc23, json-glib-1.2.0-1.fc23, libappstream-glib-0.5.16-2.fc23, libgusb-0.2.9-1.fc23, libhif-0.2.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fad11727bf

Comment 29 Fedora Update System 2016-07-20 23:49:27 UTC
PackageKit-1.1.3-1.fc23, appstream-data-23-11.fc23, fwupd-0.7.2-2.fc23, gnome-shell-3.18.5-2.fc23, gnome-software-3.20.4-1.fc23, json-glib-1.2.0-1.fc23, libappstream-glib-0.5.16-2.fc23, libgusb-0.2.9-1.fc23, libhif-0.2.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.