Bug 134575

Summary: anaconda fails on system with lots of disks
Product: Red Hat Enterprise Linux 4 Reporter: Jesse Barnes <jbarnes>
Component: anacondaAssignee: Jeremy Katz <katzj>
Status: CLOSED CURRENTRELEASE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.0CC: pnasrat
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-10-14 17:30:00 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jesse Barnes 2004-10-04 18:17:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)

Description of problem:
In trying to install on a system with 130 disks, I get this backtrace:
Starting graphical installation...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1062, in ?
    iutil.makeDriveDeviceNodes()
  File "/usr/lib/anaconda/iutil.py", line 457, in makeDriveDeviceNodes
    isys.makeDevInode(drive, "/dev/%s" % (drive,))
  File "/usr/lib/anaconda/isys.py", line 393, in makeDevInode
    _isys.mkdevinode(name, fn)
SystemError: (2, 'No such file or directory')
install exited abnormally


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
    

Additional info:

Comment 1 Jeremy Katz 2004-10-04 18:38:33 UTC
Added a fix in CVS.

Comment 2 Jesse Barnes 2004-10-07 15:54:11 UTC
Works now.