Bug 1349351

Summary: [Docs][SHE] Swap the order of two commands for removing a host
Product: Red Hat Enterprise Virtualization Manager Reporter: Jiri Belka <jbelka>
Component: DocumentationAssignee: Megan Lewis <melewis>
Status: CLOSED CURRENTRELEASE QA Contact: Tahlia Richardson <trichard>
Severity: low Docs Contact:
Priority: medium    
Version: 3.6.7CC: gklein, lbopf, lsurette, rbalakri, srevivo, thildred, ykaul, ylavi
Target Milestone: ovirt-3.6.10   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-12-06 00:41:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Docs RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jiri Belka 2016-06-23 09:57:19 UTC
Description of problem:

The order below did not work for me

~~~
# rm /etc/ovirt-hosted-engine/hosted-engine.conf
# unpersist /etc/ovirt-hosted-engine/hosted-engine.conf
~~~

taken from

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Self-Hosted_Engine_Guide/Removing_a_Host_from_a_Self-Hosted_Engine_Environment.html

~~~
[root@dell-r210ii-04 admin]# rm -f /etc/ovirt-hosted-engine/hosted-engine.conf
rm: cannot remove ‘/etc/ovirt-hosted-engine/hosted-engine.conf’: Device or resource busy
~~~

I suppose this is because the file is in `mount' output:

/dev/mapper/HostVG-Config on /etc/ovirt-hosted-engine/hosted-engine.conf type ext4 (rw,noatime,seclabel,data=ordered)

This is the order which worked for me:

~~~
[root@dell-r210ii-04 ~]# unpersist /etc/ovirt-hosted-engine/hosted-engine.conf
/etc/ovirt-hosted-engine/hosted-engine.conf successully unpersisted
[root@dell-r210ii-04 ~]# rm /etc/ovirt-hosted-engine/hosted-engine.conf
rm: remove regular file ‘/etc/ovirt-hosted-engine/hosted-engine.conf’? y
[root@dell-r210ii-04 ~]# mount -vvv | grep /etc/ovirt-hosted-engine
/dev/mapper/HostVG-Config on /etc/ovirt-hosted-engine/iptables.example type ext4 (rw,noatime,seclabel,data=ordered)
/dev/mapper/HostVG-Config on /etc/ovirt-hosted-engine/answers.conf type ext4 (rw,noatime,seclabel,data=ordered)
~~~

Version-Release number of selected component (if applicable):
3.6.7
Red Hat Enterprise Virtualization Hypervisor release 7.2 (20160621.0.el7ev)


How reproducible:
100%

Steps to Reproduce:
1. rhevh Red Hat Enterprise Virtualization Hypervisor release 7.2 (20160621.0.el7ev)

2.
3.

Actual results:
the instruction does not work

Expected results:
should work

Additional info:

Comment 1 Lucy Bopf 2016-11-18 01:16:40 UTC
Assigning to Megan for review.