Bug 136048

Summary: lvm went kablooie
Product: [Fedora] Fedora Reporter: Bill Nottingham <notting>
Component: lvm2Assignee: Alasdair Kergon <agk>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: barryn, katzj, pnasrat, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-12-08 17:55:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 123268, 136451    
Attachments:
Description Flags
LVM. It's funtastic!
none
more breakage none

Description Bill Nottingham 2004-10-17 06:05:02 UTC
As an aside, we should probably work on ways to get these dumps
somewhere other than craptastic floppy drives.

Comment 1 Bill Nottingham 2004-10-17 06:07:00 UTC
Created attachment 105343 [details]
LVM. It's funtastic!

Comment 2 Bill Nottingham 2004-10-17 06:10:36 UTC
Created attachment 105344 [details]
more breakage

This is what happened when I just tried to reboot anaconda on the same box
after it crashed. Worked around by nuking the disk, of course. :/

Comment 3 Bill Nottingham 2004-10-17 06:17:57 UTC
Preliminary guess is that it didn't like /dev/md14.

Comment 4 Jeremy Katz 2004-10-17 22:09:18 UTC
This is ... suspicious.

  Volume group VolGroup00 metadata is inconsistent
  Volume group for uuid not found:
h2MpTBWmWmJqnw068Hx6BCesvGwXiIKVwlCd3BFpqgBXHdz3VN281cUyay6MYHiQ
  Failed to activate new LV.
ata.
    Creating volume group backup "/etc/lvm/backup/VolGroup00"
  Volume group "VolGroup00" successfully created
l volumes for volume group VolGroup00.
  format_text: _vg_read failed to read VG VolGroup00
    Set up physical volume for "/dev/md0" with 163829376 available sectors
  Physical volume "/dev/md0" successfully created

Comment 5 Alasdair Kergon 2004-11-24 22:41:45 UTC
2.00.27 will help fix this - may need anaconda changes or further lvm2
changes too

Comment 6 Sc 2004-11-26 05:54:21 UTC
I too have this issue when trying to attach existing Sata raid drives.

Comment 7 Alasdair Kergon 2004-12-03 19:30:15 UTC
Does 2.00.29 fix this?

Comment 8 Bill Nottingham 2004-12-03 20:54:44 UTC
I don't have the filesystem in a state to reproduce this now. :/

Comment 9 Alasdair Kergon 2004-12-08 17:55:38 UTC
I'll assume the md-recognition code in 2.00.29 probably fixed it and
close this.