Bug 1368

Summary: rc.sysinit changes console font
Product: [Retired] Red Hat Raw Hide Reporter: sds
Component: initscriptsAssignee: Bill Nottingham <notting>
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-19 22:06:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description sds 1999-02-28 04:52:46 UTC
I set vga= in lilo.conf and /sbin/setsysfont called
from /etc/rc.d/rc.sysinit screws it up.

Comment 1 Bill Nottingham 1999-03-08 18:55:59 UTC
what version of initscripts are you running?

Comment 2 sds 1999-03-09 14:13:59 UTC
$ rpm -q initscripts
initscripts-3.91-1

Comment 3 Bill Nottingham 1999-03-09 15:53:59 UTC
what does your /etc/sysconfig/i18n say?

Comment 4 sds 1999-03-09 16:09:59 UTC
the file is empty:

$ ls -l /etc/sysconfig/i18n
   0 -rw-rw-r--   1 root     root            0 Dec  2 20:05
/etc/sysconfig/i18n

while I'd appreciate being able to display cyrillic-koi8 in the
console, I find preserving the size (60x80) more important.

Comment 5 Bill Nottingham 1999-03-10 16:46:59 UTC
Grumble. It shouldn't be doing that anymore.
Does /sbin/setsysfont look like the following?

#!/bin/sh

if [ -f /etc/sysconfig/i18n ]; then
  . /etc/sysconfig/i18n
fi

if [ -x /usr/bin/setfont ]; then

  if [ -n "$SYSFONT" -a -n "$UNIMAP" ]; then
    /usr/bin/setfont $SYSFONT -u $UNIMAP
  elif [ -n "$SYSFONT" ]; then
    /usr/bin/setfont $SYSFONT
#  else
#    /usr/bin/setfont
  fi

else
  echo "can't set font"
  exit 1
fi

Comment 6 sds 1999-03-10 23:28:59 UTC
yep, that's exactly what I have.

Comment 7 Bill Nottingham 1999-03-11 16:37:59 UTC
Check through your initscripts to see if $SYSFONT is assigned
somewhere else; if it isn't, it obviously shouldn't be
calling setfont.

Comment 8 Bill Nottingham 1999-03-19 22:06:59 UTC
at this point, I can't reproduce this here.
Using recent initscripts, the console stays the
same when booting with vga=ext, vga=132x43 (or whatever.)