Bug 137298

Summary: PPC build do not contain DRI modules
Product: [Fedora] Fedora Reporter: Ralf Ertzinger <redhat-bugzilla>
Component: xorg-x11Assignee: X/OpenGL Maintenance List <xgl-maint>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideKeywords: FutureFeature
Target Milestone: ---   
Target Release: ---   
Hardware: powerpc   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-12-02 12:21:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Ralf Ertzinger 2004-10-27 12:00:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
The PPC builds of xorg do not contain the DRI modules, these are
present in the i386 packages.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12

How reproducible:
Always

Steps to Reproduce:
1. Try to use DRI on ppc
2.
3.
    

Actual Results:  No modules present

Expected Results:  Modules present and working

Additional info:

Comment 1 Mike A. Harris 2004-10-29 03:06:51 UTC
Currently, PPC architecture intentionally has DRI disabled.  The PPC
builds are intended mainly for IBM pSeries/iSeries platforms where
stability of the X server is of utmost importance, and OpenGL hardware
acceleration is of little value in comparison.

Now however, with more and more people desiring a Fedora/PPC
official distro (including many Red Hatters too), and the majority
of potential Fedora/PPC users being Mac users, we will need to
explore making a separate DRI enabled PPC build of X specifically
for Fedora Core, while keeping DRI disabled for our official
RHEL4/PPC builds for IBM server hardware.

In the mean time, the spec file has this conditionalized to be
easy to enable and rebuild.  Fedora/PPC users wanting DRI support
in the mean time may want to rebuild the src.rpm until we have
official rpms with DRI enabled in the future.

Thanks.

Comment 2 Ralf Ertzinger 2004-10-29 11:45:25 UTC
If official packages will have DRI in the not too far future, I am
willing to wait for that.

Thanks.

Comment 3 Ralf Ertzinger 2004-12-02 12:21:04 UTC
OK, it seems like there are DRI modules in the current rawhide
packages. I haven't gotten them to work, yet, but that's another
story. Thanks.