Bug 139842

Summary: missing Requires: python-abi = %{pyver}
Product: [Fedora] Fedora Reporter: Joe Orton <jorton>
Component: kdebindingsAssignee: Ngo Than <than>
Status: CLOSED RAWHIDE QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-11-18 14:52:25 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Joe Orton 2004-11-18 13:23:26 UTC
kdebindings needs rebuilding against Python 2.4 and is missing a
"Requires: python-abi" like:

%define pyver %(%{__python} -c "import sys; print sys.version[:3]")
...
Requires: python-abi = %{pyver}

Comment 1 Ngo Than 2004-11-18 14:24:24 UTC
python binding (sip and pyqt) is always disable in the kdebinding. we
have both as separate packages.

Therefore it's not needed to add this requires here.

Comment 2 Ngo Than 2004-11-18 14:27:11 UTC
oh sorry, it's yet needed for dcop! it will be fixed in next rebuild

Comment 3 Joe Orton 2004-11-18 14:37:41 UTC
$ rpm -q kdebindings
kdebindings-3.3.1-1.i386
$ rpm -ql kdebindings | grep python
/usr/lib/python2.3
/usr/lib/python2.3/pydcop.py
/usr/lib/python2.3/site-packages
/usr/lib/python2.3/site-packages/pcop.la
/usr/lib/python2.3/site-packages/pcop.so

and the "Requires: python-abi = pyver" change is required to correctly
enforce matching of python modules with python interpreter version.

Comment 4 Ngo Than 2004-11-18 14:52:25 UTC
please read Comment #2 ;-) i have overlooked this

Comment 5 Joe Orton 2004-11-18 19:23:06 UTC
$ rpm -qp --requires kdebindings-3.3.1-3.i386.rpm  | grep python-abi
$

what am I missing?

Comment 6 Ngo Than 2004-11-19 10:56:09 UTC
it's now definitely fixed in 3.3.1-4 ;-)