Bug 141321

Summary: keyboard (i8042) does not work with smp kernel on Dell 350
Product: [Fedora] Fedora Reporter: Gene Czarcinski <gczarcinski>
Component: kernelAssignee: Dave Jones <davej>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: high Docs Contact:
Priority: medium    
Version: 3CC: pfrields, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-06-01 17:07:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
dmesg after up boot
none
dmesg after smp boot none

Description Gene Czarcinski 2004-11-30 13:13:47 UTC
Description of problem:

The hardware is a Dell Precision 350 workstation with dual processors.

When I boot up with the up kernel, everything works OK.  When I boot
up with the smp kernel, the keyboard does not work.  The mouse is a
USB mouse (it works) although I have also tried a ps2 mouse and it
worked OK also.

The keyboard does work with grub and only stops after the kernel is
booted.

I will be attaching dmesg for a up and smp bootup but the important
message seems to be:

with the up kernel (it works), I get:

  serio: i8042 KBD port at 0x60,0x64 irq 1

whereas with the smp kernel (it does not work), I get:

  i8042.c: Can't read CTR while initializing i8042.

This started with the kernel from the FC3 install but is still there
with the 2.6.9-1.681_FC3 kernel.

There is no kvm switch used (direct plugins).

I have tried the current RHEL beta1 and there is no difference.  I
also tried FC2 and there was no difference (still did not work).  I
will be trying FC1 to see if that works since it uses the 2.4 kernel.

We have a couple of these 350 workstations and would like to use FC3
or RHEL when the new one is released but this is not promising.  We
are in the process of trying gentoo and debian on them also.

I have searched bugzilla.kernel.org as well as the kernel mailing list
and can find no reference to a problem like this.  Although there are
currently only a few patches to the base kernel, I do notice that one
of the patches is to the 8042 code so this may well be Fedora Core/Red
Hat specific.

Yes, I did something I do not usually do and set the bug severity to
High because this is impacting our ability to use this hardware.

This may be related to
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=136732 but there
is no BIOS option for disabling legacy USB support on the Dell 350.

Comment 1 Gene Czarcinski 2004-11-30 13:15:20 UTC
Created attachment 107621 [details]
dmesg after up boot

Comment 2 Gene Czarcinski 2004-11-30 13:15:59 UTC
Created attachment 107622 [details]
dmesg after smp boot

Comment 3 Gene Czarcinski 2005-06-01 17:06:04 UTC
I should have closed this report some time ago but forgot.

I have a "fix" for my problem -- add the kernel parameter "usb-handoff" and the
smp kernel now works fine ... this works for kernel => 2.6.10

Also see https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=136732