Bug 142234

Summary: ACPI no longer works but used to in FC2
Product: [Fedora] Fedora Reporter: Nicholas Allen <nick.allen>
Component: kernelAssignee: Dave Jones <davej>
Status: CLOSED CURRENTRELEASE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 3CC: intel-linux-acpi, peter.farmer, pfrields, vlada, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-07-15 23:11:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Nicholas Allen 2004-12-08 11:00:40 UTC
Description of problem:

Using ACPI in FC3 no longer works. Only some events are reported and
the battery status is incorrectly reported (never changes unless I
plug in the AC adapter and remove it). Most often the unplugging of
the AC adapter creates no events in /proc/acpi/event. The lid open and
close events are also not reported.

I used to have no problems with this on FC2 and also FC1.

Version-Release number of selected component (if applicable):

kernel-2.6.9-1.667

How reproducible:

Everytime

Steps to Reproduce:
1.Boot laptop with ACPI enabled
2.stop acpid and the cat /proc/acpi/event and see that npt all events
are reported and that false battery status is also reported
3.
  
Actual results:


Expected results:

All events should be correctly reported.

Additional info:

Comment 1 Vladimir Kotal 2004-12-16 22:45:53 UTC
This is not only laptop issue but also generic ACPI brokeness. Trying
to turn off computer with Gigabyte GA-7VT880L - VIA KT880 motherboard
hangs after acpi command is issued. Turning off the computer worked in
FC2.

Comment 2 Peter Farmer 2005-01-27 14:47:37 UTC
I have a similiar set of problems with FC3 on an Acer Aspire 1684 
(kernel 2.6.10-1.741). Battery management via acpi is not functional 
even though the acpi driver has initialised w/o errors: 
 
ACPI: Power Resource [PFN0] (off) 
ACPI: Power Resource [PFN1] (off) 
ACPI: Fan [FAN0] (off) 
ACPI: Fan [FAN1] (off) 
ACPI: Processor [CPU0] (supports C1 C2 C3) 
ACPI: Processor [CPU0] (supports 8 throttling states) 
ACPI: Thermal Zone [THRM] (55 C) 
speedstep-centrino: invalid ACPI data 
speedstep-centrino: try compiling with 
CONFIG_X86_SPEEDSTEP_CENTRINO_ACPI enabled 
ACPI wakeup devices: 
ACPI: (supports S0 S3 S4 S5) 
ACPI: Power Button (FF) [PWRF] 
ACPI: Lid Switch [LID] 
ACPI: Sleep Button (CM) [SLPB] 
 
The KDE Battery Management control reports : 
 
Your computer seems to have a partial ACPI installation. ACPI was 
probably enabled, but some of the sub-options were not - you need to 
enable at least 'AC Adaptor' and 'Control Method Battery' and then 
rebuild your kernel . This is confirmed by the lack of any files in 
the /proc/acpi/ac_adapter/ and /proc/acpi/battery/ directories. 
 
Some events are reported by acpi_listen - the lid, sleep & power 
buttons. But none for battery or ac adapter. 
 
HTH 

Comment 3 Vladimir Kotal 2005-01-27 16:26:47 UTC
Kernel update to 2.6.10-1.741_FC3 fixed this issue for me.

Comment 4 Dave Jones 2005-02-24 07:20:19 UTC
Nicholas, can you try the latest errata please ?

Comment 5 Nicholas Allen 2005-02-24 15:30:56 UTC
I just tried with 2.6.10-1.766_FC3 kernel and more events seen to be reported 
but sometimes an ac unplug is not noticed at all and a lid close or open is 
not reported or is reproted the next time I plug the ac adapter in (which can 
be a very long time after the lid is open/closed). 

Comment 6 Dave Jones 2005-07-15 18:21:22 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 7 Vladimir Kotal 2005-07-15 21:50:36 UTC
No, this problem is not present in FC4 and I belive it is fixed in FC3 as well. Since FC2 is now probably 
considered obsolete, you can close this bug.