Bug 143889

Summary: libtool paths for g++ are stale
Product: [Fedora] Fedora Reporter: Jonathan S. Shapiro <shap>
Component: libtoolAssignee: Daniel Reed <djr>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-01-03 23:12:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jonathan S. Shapiro 2004-12-31 18:35:11 UTC
Description of problem:

When building shared libraries using

   libtool --mode=link g++ -o foo.la ...objects... -rpath somedir

libtool attempts to reference to the crti files living in
/usr/lib/gcc/i386-redhat-linux/3.4.1/. This doesn't work, since both
gcc and g++ have been updated to versions 3.4.2 since the last update
of libtool.

Version-Release number of selected component (if applicable):

   libtool-1.5.6-4

How reproducible:

   In a convenient FC3 shell and an empty directory
   Type: libtool --mode=link g++ -o fred.la fred.o -rpath /lib
   Watch the diagnostics to see that the wrong paths are referenced
  
Actual results:


Expected results:

   Well, I definitely don't expect that command to work, since
   there isn't any fred.o, but making reference to a bad path
   definitely wasn't the expected failure mode. :-)


Additional info:

   I rebuilt libtool locally by hand from the SRPM, deinstalled
   the fedora-supplied binary rpm and installed my newly built
   version. This "solved" the problem, so it looks like the
   existing libtool package may simply need to be

Comment 1 Daniel Reed 2005-01-03 22:58:01 UTC
*** Bug 143890 has been marked as a duplicate of this bug. ***

Comment 2 Daniel Reed 2005-01-03 23:02:02 UTC
I'm going to have to figure out why this is getting hardcoded in at all.

Comment 3 Daniel Reed 2005-01-03 23:12:39 UTC

*** This bug has been marked as a duplicate of 140977 ***