Bug 1440331

Summary: GStreamer Multimedia Codecs - H.264 cannot be installed
Product: [Fedora] Fedora Reporter: Chris Murphy <bugzilla>
Component: gnome-softwareAssignee: Richard Hughes <rhughes>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 26CC: a.vozhdaenko, cgerardin, cmeadors, digitalfreak, ehabkost, gpulido, hgomes, jonathan.underwood, klember, mail, rfindeis, rhughes, shane, xiliang
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: gnome-software-3.28.1-1.fc27 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-19 00:29:19 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1411236, 1478991    
Bug Blocks:    
Attachments:
Description Flags
software --verbose log
none
enable 3rd party screenshot none

Description Chris Murphy 2017-04-07 23:45:33 UTC
Created attachment 1269955 [details]
software --verbose log

Description of problem:

Gnome Software won't install GStreamer Multimedia Codecs - H.264 and presents no error why it won't install.




Version-Release number of selected component (if applicable):
gnome-software-3.24.0-1.fc26.x86_64
PackageKit-1.1.5-4.fc26.x86_64

How reproducible:
Always


Steps to Reproduce:
1. Gnome Software, click add-ons, click GStreamer Multimedia Codecs - H.264, click install
2. Accept enabling 3rd party software
3.

Actual results:

Exactly nothing happens in the GUI. No installation, no error, no poof, nada, nothingburger. Not even a sad panda.


However --verbose has a clue

23:34:35:0387 Gs  failed to install gstreamer-openh264: [system/package/fedora/codec/gstreamer-openh264/*] repo already enabled



Expected results:

Install the goods.

Additional info:

Comment 1 Chris Murphy 2017-04-07 23:51:36 UTC
Created attachment 1269956 [details]
enable 3rd party screenshot

This pop-up says it's provided by "fedora" which isn't 3rd party to me, so in retrospect this dialog seems specious.

Comment 2 Xiao, Liang 2017-10-12 01:30:33 UTC
It does not work on my Fedora26 when I try to play mp4 files. There are several dup bugs against this plugin.
It impacts user's experience in multimedia using Fedora. So, could you evaluate this problem and assign it to the right component if needed?

Comment 3 Xiao, Liang 2017-10-12 09:58:07 UTC
I found a workaround in below link, which, at least, makes my player works on my Fedora26.
Just need to follow the step1~step3.
http://www.binarytides.com/multimedia-codecs-fedora-23/

Comment 4 AsciiWolf 2017-10-24 08:58:54 UTC
Still not fixed in Fedora 27.

Comment 5 AsciiWolf 2017-11-18 12:12:52 UTC
On Fedora 27, it is now possible to click on the "Enable and Install" button. However, clicking the button displays a "repo already enabled" error message and installation is aborted.

Comment 6 AsciiWolf 2017-11-18 12:14:10 UTC
More information from Christophe Fergeau (https://bugzilla.gnome.org/show_bug.cgi?id=786038#c1):

Happens to me on f26 as well as with gnome-software master. With gnome-software master, this gives an error that the repository was already enabled.
The code goes up to gs_plugin_app_install() in gs-plugin-packagekit.c, GsApp::state is AS_APP_STATE_UNAVAILABLE so it tries to enable the repo, but for some reason it's already enabled, so an error is returned, which makes gnome-software stop the installation.

Comment 7 shane 2018-01-17 09:30:28 UTC
This is affecting me on F27 too. Suddenly, mp4 playback doesn't work, when I open a video in the Videos application I'm shown the message "H.264 (High Profile) decoder is required to play the file, but is not installed".

Below that is a "Find in Software" button, but clicking through and trying to install the codec results in the same problem above, where installation fails because the repo is supposedly already enabled.

Thus, video playback is utterly hosed on this system.

Comment 8 Kalev Lember 2018-03-01 11:34:43 UTC
I've tracked this down to a bug in setting "origin" in gnome-software, fixing it now.

Comment 10 Fedora Update System 2018-03-16 16:12:34 UTC
PackageKit-1.1.9-2.fc27 gnome-software-3.28.0-4.fc27 libappstream-glib-0.7.7-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-55a6726164

Comment 11 Fedora Update System 2018-03-17 20:38:20 UTC
PackageKit-1.1.9-2.fc27, gnome-software-3.28.0-4.fc27, libappstream-glib-0.7.7-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-55a6726164

Comment 12 Rafal Luzynski 2018-03-17 22:57:44 UTC
Kalev, can you please backport the same fix for F26?

Comment 13 Kalev Lember 2018-03-18 09:18:19 UTC
No, sorry, this change is particularly invasive and can break a lot of unrelated things.

Comment 14 Fedora Update System 2018-04-13 15:55:37 UTC
PackageKit-1.1.9-3.fc27 gnome-software-3.28.1-1.fc27 libappstream-glib-0.7.7-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-55a6726164

Comment 15 Fedora Update System 2018-04-15 16:18:51 UTC
PackageKit-1.1.9-3.fc27, gnome-software-3.28.1-1.fc27, libappstream-glib-0.7.7-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-55a6726164

Comment 16 Fedora Update System 2018-04-19 00:29:19 UTC
PackageKit-1.1.9-3.fc27, gnome-software-3.28.1-1.fc27, libappstream-glib-0.7.7-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Cameron Meadors 2018-05-02 17:49:02 UTC
I am running Fedora 27 with latest updates and the bug is still not fixed.

Comment 18 Cameron Meadors 2018-05-02 17:55:47 UTC
$ dnf list PackageKit gnome-software libappstream-glib 
Last metadata expiration check: 20 days, 22:07:08 ago on Wed 11 Apr 2018 03:43:11 PM EDT.
Installed Packages
PackageKit.x86_64                       1.1.10-1.fc27                   @updates
gnome-software.x86_64                   3.28.1-1.fc27.1                 @updates
libappstream-glib.x86_64                0.7.8-1.fc27                    @updates

Comment 19 Cameron Meadors 2018-05-02 19:23:23 UTC
I added the rpmfusion repo and the gstreamer package installed because that was the external repo it was trying to add.

Comment 20 Kalev Lember 2018-05-02 20:24:12 UTC
Can you open a new bug with a detailed description what's going wrong, and how to reproduce it, please? The original issue here should be fixed.

Comment 21 hgomes 2018-05-12 12:45:53 UTC
After doing these steps, it works.

sudo dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm
sudo dnf install gstreamer1-libav