Bug 1445328 (CVE-2017-8070)

Summary: CVE-2017-8070 kernel: catc.c interacts incorrectly with the CONFIG_VMAP_STACK option
Product: [Other] Security Response Reporter: Adam Mariš <amaris>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: aquini, bhu, dhoward, fhrbata, gansalmon, hwkernel-mgr, iboverma, ichavero, itamar, jforbes, jkacur, jonathan, jross, jwboyer, kernel-maint, kernel-mgr, labbott, lgoncalv, madhu.chinakonda, matt, mchehab, mcressma, nmurray, pholasek, plougher, rt-maint, rvrbovsk, williams
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-06-08 03:11:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 1445344    
Bug Blocks:    

Description Adam Mariš 2017-04-25 13:43:02 UTC
drivers/net/usb/catc.c in the Linux kernel 4.9.x before 4.9.11
interacts incorrectly with the CONFIG_VMAP_STACK option, which allows
local users to cause a denial of service (system crash or memory
corruption) or possibly have unspecified other impact by leveraging
use of more than one virtual page for a DMA scatterlist.

Upstream patch:

https://github.com/torvalds/linux/commit/2d6a0e9de03ee658a9adc3bfb2f0ca55dff1e478

Comment 1 Adam Mariš 2017-04-25 13:53:03 UTC
Created kernel tracking bugs for this issue:

Affects: fedora-all [bug 1445344]

Comment 2 Justin M. Forbes 2017-04-25 21:37:33 UTC
All Fedora releases have been on 4.10.x or newer for some time now.