Bug 149778

Summary: Package dependency problem: grisbi <--> libofx
Product: [Fedora] Fedora Reporter: Sven Wahl <svenwahl>
Component: grisbiAssignee: Aurelien Bompard <gauret>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 3CC: moe
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-03-24 12:09:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Sven Wahl 2005-02-26 15:33:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1

Description of problem:
Red Hat published an update for the LibOFX library in FC3 the other day,
which brings libofx from version 0.6.6 to version 0.7.0.

Having grisbi from Fedora Extras installed, I stumbled across a package
dependency problem when trying to update libofx:
grisbi-0.5.5-1 requires libofx.so.0, which is provided by libofx-0.6.6,
but the updated libofx with version 0.7.0 provides libofx.so.1 instead.


Version-Release number of selected component (if applicable):
grisbi-0.5.5-1

How reproducible:
Always

Steps to Reproduce:
1. Attempting to update libofx-0.6.6 to version 0.7.0  

Actual Results:  Unresolvable chain of dependencies:
grisbi  0.5.5-1                          requires libofx.so.0

Additional info:

Comment 1 Seth Vidal 2005-02-26 16:50:06 UTC
does this need anything more than a rebuild?

Comment 2 Aurelien Bompard 2005-02-26 17:00:15 UTC
No, a simple rebuild is enough. I was waiting for the anwer about epochs to
commit my update. Now it's done. I'll update the wiki.

Comment 3 Sven Wahl 2005-03-01 08:55:18 UTC
Thanks for rebuilding grisbi! But -- I'm sorry to say it -- the package
dependency conflict described in this bug persists. The new grisbi-0.5.5-2
package still requires libofx.so.0.


Comment 4 Michael Schwendt 2005-03-01 12:34:38 UTC
Then increase the libofx-devel build requirement to >= 0.7.0 to make sure the
right soname is built against.

Comment 5 Michael Schwendt 2005-03-01 20:46:30 UTC
*** Bug 150032 has been marked as a duplicate of this bug. ***

Comment 6 Sven Wahl 2005-03-21 21:13:12 UTC
Could someone with CVS access please follow up this bug (i.e. increase the
libofx-devel build requirement in the grisbi specfile to >= 0.7.0 -- as Michael
suggested --  and request a rebuilt).

Thanks!


Comment 7 Aurelien Bompard 2005-03-21 21:18:34 UTC
Yes sorry, I'll do that now.