Bug 150463

Summary: DRI not enabled for ATI Radeon 9200
Product: Red Hat Enterprise Linux 4 Reporter: Tomas Mraz <tmraz>
Component: xorg-x11Assignee: Mike A. Harris <mharris>
Status: CLOSED NOTABUG QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.0CC: davej, riel
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-03-07 22:11:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tomas Mraz 2005-03-07 11:15:44 UTC
Description of problem:
With kernel-2.6.9-5.EL no /dev/dri/card0 appears and in dmesg there is
no message about the ATI Radeon card I have. The computer is with AMD
Athlon and SiS 745 chipset. If I use vanilla 2.6.10 kernel with
agpgart, sis-agp as module and load the modules either by hand or by
using modprobe.conf it works fine. I even tried upgrading to
kernel-2.6.10-1.770_FC3 and it didn't help.
Even if I do modprobe radeon later it doesn't help because it only
initializes the DRM however the DRI stays switched off.

How reproducible:
100%

Expected results:
DRI works out of the box with the supplied kernel.

Comment 1 Dave Jones 2005-03-07 20:18:45 UTC
we disabled it in X for GA due to stability concerns, it'll be fixed in U1 I
believe? Mike ?

Comment 2 Mike A. Harris 2005-03-07 22:11:40 UTC
DRI is disabled by default in the current xorg-x11 for RHEL4.  You have
to enable DRI manually in the config file.