Bug 151671

Summary: gcj fails compiling a class that mailine does not
Product: [Fedora] Fedora Reporter: Andrew Overholt <overholt>
Component: gccAssignee: Jakub Jelinek <jakub>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 4.0.0-0.35 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-03-21 23:17:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Andrew Overholt 2005-03-21 16:34:14 UTC
Description of problem:
The gcj in the latest gcc RPM fails to compile a class while mainline HEAD does
not fail.

Version-Release number of selected component (if applicable):
gcc-java-4.0.0-0.34

How reproducible:
Always

Steps to Reproduce:
1. wget http://people.redhat.com/overholt/JavadocOptionsManager.class
2. gcj -fPIC -fjni -findirect-dispatch -shared -Wl,-Bsymbolic -O2 -o
JavadocOptionsManager.class.so JavadocOptionsManager.class
  
Actual results:
org/eclipse/jdt/internal/ui/javadocexport/JavadocOptionsManager.java: In class
'org.eclipse.jdt.internal.ui.javadocexport.JavadocOptionsManager':
org/eclipse/jdt/internal/ui/javadocexport/JavadocOptionsManager.java: In method
'org.eclipse.jdt.internal.ui.javadocexport.JavadocOptionsManager.createXML(org.eclipse.jdt.core.IJavaProject[])':
org/eclipse/jdt/internal/ui/javadocexport/JavadocOptionsManager.java:0: internal
compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.

Expected results:
No output.

Additional info:

This works for me with CVS tip as of last week:

$ gcj --version
gcj (GCC) 4.1.0 20050317 (experimental)

I think it will also work with the 4.0 branch HEAD but I don't have a copy of
that to try.

Comment 1 Jakub Jelinek 2005-03-21 23:17:15 UTC
While I could reproduce this with gcc-4.0.0-0.34, I can't with 4.0.0-0.35.
Assuming this is fixed...