Bug 1597657

Summary: dnf-system-upgrade.service should have "After=system-update-pre.target" in its [Unit] section
Product: [Fedora] Fedora Reporter: Hans de Goede <hdegoede>
Component: dnf-plugins-extrasAssignee: rpm-software-management
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 28CC: dmach, jkadlcik, jmracek, mblaha, rpm-software-management, vmukhame
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: dnf-4.0.4 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-11-22 18:37:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Hans de Goede 2018-07-03 11:22:31 UTC
Per the updated systemd.offline-updates manpage:
https://www.freedesktop.org/software/systemd/man/systemd.offline-updates.html

dnf-system-upgrade.service should have "After=system-update-pre.target" in its [Unit] section since systemd-239. A .service file with this added can be safely used with older versions of systemd too.

Comment 1 Marek Blaha 2018-07-03 12:16:37 UTC
Thanks for info.
PR https://github.com/rpm-software-management/dnf-plugins-extras/pull/129