Bug 17030

Summary: Installer dies with traceback if list of pkgs to be installed is customized
Product: [Retired] Red Hat Linux Reporter: Andrea Borgia <andrea.borgia>
Component: anacondaAssignee: Brock Organ <borgan>
Status: CLOSED RAWHIDE QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 7.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-08-29 20:27:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Traceback dump
none
TUI traceback none

Description Andrea Borgia 2000-08-28 12:11:43 UTC
Expert mode install, english language, customized list of packages: dies with a traceback when running mkdosfs.
(quoting from memory) I have sda1 as /dosc, sda5 as /dosd (NTFS), sda6 as /, sda7 as /usr, sdb1 as /dose, sdb5 as /var, sdb6 as /home
and sdb7 as swap.
I had selected about 840MB of packages, then the installer formatted /, /usr and died.
It does not happen without expert mode enabled.

Comment 1 Andrea Borgia 2000-08-28 12:12:31 UTC
Created attachment 3060 [details]
Traceback dump

Comment 2 Andrea Borgia 2000-08-28 12:16:17 UTC
Oh, and "no filesystems were harmed in the making of this traceback" ;-)
Meaning that DOS and NTFS partitions appear to be fine.

Comment 3 Andrea Borgia 2000-08-28 19:45:35 UTC
My previous report was slightly off the mark: expert mode/mkdosfs is not the problem, customizing the list is!
To reproduce (maybe you don't need to do exactly as I did, but you never know): cd install, select 105keys ita kdb
with dead keys, logitech mouseman, custom system, disk druid (sda1->/dosc, sda5->/dosd NTFS, sda6->/,
sda7->/usr, sdb5->/home, sdb6->/var, sdb7->swap, sdb8->/dose), format all linux partitions, no bootdisk,
use linear, default to dos, Europe/Rome, UTC+2, use DST,
Customize list:
no changes: ok
some changes: traceback
I hadn't noticed it before because the schedule was so tight that other bugs took precedence and never spent
any time customizing the list... I select the subsystems and let it go.


Comment 4 Michael Fulbright 2000-08-29 15:54:47 UTC
Brock please reproduce.

Comment 5 Brock Organ 2000-08-29 18:57:26 UTC
hmmm ... I could not reproduce this problem in test with the steps above ... :(

* tried italian & english GUI
* tried partitions as described above
* tried expert & non-expert modes
* tried lilo config as above

Comment 6 Andrea Borgia 2000-08-29 19:45:42 UTC
Have you tried it with RC2 or with a newer cut? Please test RC2, also, because I managed to reproduce it on a differen system:
hda1->/dosc, hda5->/dosd, hda6->/, hda7->swap; italian GUI (other was TUI), customized list... traceback.
Here it comes...


Comment 7 Andrea Borgia 2000-08-29 19:48:49 UTC
Created attachment 3084 [details]
TUI traceback

Comment 8 Andrea Borgia 2000-08-29 19:50:06 UTC
Sorry, I meant "Italian TUI (other was GUI)".


Comment 9 Brock Organ 2000-08-29 20:27:43 UTC
verified this problem using the RC2 CDs (my fault for not using them in the
first place... :( )

this issue is verified fixed in internal builds (RC-4 & above)... thanks for
your report!