Bug 17047

Summary: Startupposition conflicts with named
Product: [Retired] Red Hat Linux Reporter: Enrico Scholz <rh-bugzilla>
Component: xinetdAssignee: Trond Eivind Glomsrxd <teg>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 7.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-08-30 15:34:22 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Enrico Scholz 2000-08-28 18:38:11 UTC
`man xinetd.conf' says nearly `only_from' (paragraph d):

d) a  host name.  When a connection is made to xinetd, a reverse
    lookup is performed, and the canonical name returned is  com-
    pared  to  the  specified host name.  You may also use domain
    names in the form of .domain.com.  If the reverse  lookup  of
    the client's IP is within .domain.com, a match occurs.

When running an own named (nameserver is 127.0.0.1) use of e.g

| only_from = host.local.zone

results in a parsing error during startup. 

This happens because xinetd starts at position 50, but named laterly at pos
55. So DNS lookups done by xinetd will fail.

Comment 1 Trond Eivind Glomsrxd 2000-08-29 15:20:48 UTC
Hmmm.... will fix

Comment 2 Trond Eivind Glomsrxd 2000-08-30 15:34:20 UTC
Fixed.