Bug 18053

Summary: Installation error
Product: [Retired] Red Hat Linux Reporter: Need Real Name <scanez>
Component: anacondaAssignee: Brock Organ <borgan>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 7.0CC: andrew, arsmith, ykatchen
Target Milestone: ---   
Target Release: ---   
Hardware: i586   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-12-08 19:52:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Need Real Name 2000-10-02 04:34:07 UTC
Installation stops with this error

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in 
doInstall
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 703, in 
mountFilesystems
  File "/usr/lib/anaconda/isys.py", line 46, in losetup
    targ = os.open(file, mode)
OSError: [Errno 2] No such file or directory: '/mnt/loophost/redhat.img'

Local variables in innermost frame:
file: /mnt/loophost/redhat.img
mode: 2
readonly: 0
device: /tmp/loop1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I0
sS'fnames'
p9
(dp10

<failed>

Comment 1 Michael Fulbright 2000-10-02 22:09:12 UTC
Which partition were you installing Linux to, and which partition were you
installing from?

Comment 2 Michael Fulbright 2000-10-09 15:25:59 UTC
*** Bug 18623 has been marked as a duplicate of this bug. ***

Comment 3 Michael Fulbright 2000-10-09 15:41:42 UTC
*** Bug 18577 has been marked as a duplicate of this bug. ***

Comment 4 Scott E. Eddy 2000-10-09 22:43:15 UTC
I had duplicate 18623, and I was trying to do a partitionless install on a 
machine with Windows ME installed.  I have over 3GB of free space, so that 
wasn't the issue.

Other Info:
Celeron 566
Installation from Hard Disk from Downloaded files.

Comment 5 Michael Fulbright 2000-11-03 20:07:23 UTC
*** Bug 20158 has been marked as a duplicate of this bug. ***

Comment 6 Need Real Name 2000-11-06 05:23:40 UTC
Trying to install on a IBM Thinkpad 570E, 3 gigs free, 450 Mhz PIII with 196 
megs ram.  I get the same error:
 
targ = os.open(file, mode)
OSError: [Errno 2] No such file or directory: '/mnt/loophost/redhat.img'



Comment 7 Michael Fulbright 2000-11-15 16:58:06 UTC
It would be extremely helpful to have the exact steps you took that caused this
problem so we could reproduce it here.

Comment 8 Michael Fulbright 2000-11-22 17:18:18 UTC
Fixed in internal development tree.

Comment 9 Michael Fulbright 2000-11-22 17:19:10 UTC
*** Bug 21224 has been marked as a duplicate of this bug. ***

Comment 10 Michael Fulbright 2000-11-22 17:20:21 UTC
This bug occurs because currently you cannot do an partionless install from the
same drive you are installing from during a hard drive install method. You can
use the ISO images available to burn CDs and try the partitionless install however.

Comment 11 Michael Fulbright 2000-11-22 17:20:42 UTC
Fixed in CVS.

Comment 12 Michael Fulbright 2000-11-29 19:43:18 UTC
*** Bug 21365 has been marked as a duplicate of this bug. ***

Comment 13 Michael Fulbright 2000-12-04 16:53:24 UTC
*** Bug 21626 has been marked as a duplicate of this bug. ***

Comment 14 Michael Fulbright 2000-12-04 16:53:40 UTC
*** Bug 21626 has been marked as a duplicate of this bug. ***

Comment 15 Blake 2000-12-04 19:12:44 UTC
So how do you fix this bug?

Comment 16 Brock Organ 2000-12-12 23:02:46 UTC
the hard drive install method should change in the next release of red hat linux
... we will test this case to try to ensure it is resolved ...

Comment 17 Michael Fulbright 2000-12-27 16:55:26 UTC
*** Bug 22802 has been marked as a duplicate of this bug. ***

Comment 18 Michael Fulbright 2000-12-27 17:23:06 UTC
*** Bug 21003 has been marked as a duplicate of this bug. ***

Comment 19 Michael Fulbright 2001-01-17 18:02:29 UTC
*** Bug 24099 has been marked as a duplicate of this bug. ***

Comment 20 Michael Fulbright 2001-01-17 20:10:01 UTC
*** Bug 24100 has been marked as a duplicate of this bug. ***

Comment 21 Michael Fulbright 2001-01-24 20:13:07 UTC
*** Bug 24856 has been marked as a duplicate of this bug. ***

Comment 22 Michael Fulbright 2001-01-26 16:43:12 UTC
*** Bug 24446 has been marked as a duplicate of this bug. ***

Comment 23 Need Real Name 2001-01-27 11:26:11 UTC
Thanks RedHat for the info.  It worked out fine for me.

  I have a 4.3 GB hard drive that is partitioned under Windoze 95 into drive C: (hda1), drive D: (hda5), and drive E (hda6).  I put the install files on the C: 
(hda1) drive and loaded RedHat on drive D: (hda5).  Everything from there on out went without any problems.

Recommendation:  Put a short notice on the download page explaining the current two hard drive rule.   It should only take about = hour to do and it will 
save people a lot of time.  I.e. Downloading several times, trying to find the same problem in the bug reports and waiting on the support staff to list it as a 
duplicate bug.

If you're installing Red Hat Linux on an Intel machine with a formatted DOS (FAT)
filesystem, you also have the option of doing a "partitionless" install.
 
However you must install from one drive to another I.e. Intall files on
 DOS drive C: and install Red Hat to DOS Drive D. 

 See theOfficial Red Hat Linux 7.0 Installation Guide, available from
http://www.redhat.com/support/manuals/, for more information about partitionless
Installs.

  Thanks again for the help.  It worked out great.

Larry


Comment 24 Michael Fulbright 2001-03-01 19:02:15 UTC
*** Bug 30030 has been marked as a duplicate of this bug. ***

Comment 25 Michael Fulbright 2001-03-06 20:09:49 UTC
*** Bug 30829 has been marked as a duplicate of this bug. ***

Comment 26 Brent Fox 2001-10-18 14:54:07 UTC
*** Bug 54762 has been marked as a duplicate of this bug. ***