Bug 18778

Summary: MS Intellimouse (Serial) not working in RH7
Product: [Retired] Red Hat Linux Reporter: Arion <arionau>
Component: mouseconfigAssignee: Brent Fox <bfox>
Status: CLOSED WONTFIX QA Contact: David Lawrence <dkl>
Severity: high Docs Contact:
Priority: high    
Version: 7.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:47:47 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Arion 2000-10-10 07:45:51 UTC
I have tested the MS Intellimouse (Serial) on 4 PCs with RH7 and it doesn't
work. This problem was reported in RH7 Beta and said it was fixed but it
was not. In RH 6.1 and 6.2 I had to run mousetest or mouseconfig after
booting to wake the mouse up and then it worked but under RH7 Beta and RH7
it will not work at all. I got it to work in the GUI Installer by rebooting
the the CD 3 times until it worked.

Can this be fixed it has gone on for 3 versions of RH now!

Comment 1 Matt Wilson 2000-10-10 07:49:38 UTC
The serial intellimice are fickle little things.  On the model we have here
sometimes we have to leave it unplugged for hours before the mouse will return
to operating normally.  The PS/2 mouse probe code kicks the mouse into PS/2 mode
(not IMPS/2 mode) and it's hard to get it back in IMPS/2 mode.

Is the installer not seeing the mouse at all?  Or is it impossible to control
the pointer during the installation?  If you select a different mouse protocol
from the mouse selection dialog (using keyboard navigation), switching from ps/2
to imps/2 or vice versa, does that help?


Comment 2 Arion 2000-10-11 14:57:18 UTC
This only happens for Serial Intellimouse the PS/2 version works fine.

The first 2 times I boot the installer the mouse pointer would not move. The 3rd time I boot after turning off the PC for 10 mins the mouse work ok.

When I booted RH7.0 (also happened in 7.0 Beta as well) the would not work. Not with gpm and not with X. The standard MS mouse serial works though.

Choosing different mice using mouseconfig had no effect.

Comment 3 Brent Fox 2002-09-10 20:19:28 UTC
Have you seen this behavior in more recent versions of Red Hat Linux?

Comment 4 Brent Fox 2002-10-10 18:15:41 UTC
I have just completed a text mode interface for redhat-config-mouse, which means
that mouseconfig will be deprecated in the next release of Red Hat Linux.  

Therefore, I will not be putting any development time towards fixing mouseconfig
bugs, so I'm closing this as 'wontfix'.

Comment 5 Red Hat Bugzilla 2006-02-21 18:47:47 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.