Bug 189722

Summary: Automatic detection of the sound card did not work
Product: [Fedora] Fedora Reporter: Kunal Shah <kunalvshah>
Component: alsa-utilsAssignee: Martin Stransky <stransky>
Status: CLOSED UPSTREAM QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-08-09 06:37:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
/root/scsound.log
none
out of of /sbin/lspci none

Description Kunal Shah 2006-04-23 23:08:06 UTC
Description of problem:
When I run sndconfig, it shows applete that ask me to run some sound and asks if
i hear it. i dont hear anything. so when i press no there, it says 

Automatic detection of the sound card did not work,Audio will not be available
on the system.
You can inspect /root/scsound.log and file a new bug
at http://bugzilla.redhat.com.

Please click OK to continue.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.login to kde as root
2.go to system->administration->soundcard detection.
3.click on play icon, it will ask whether you hear any sound. i dont hear anything.
  
Actual results:


Expected results:


Additional info:

Comment 1 Kunal Shah 2006-04-23 23:08:06 UTC
Created attachment 128133 [details]
/root/scsound.log

Comment 2 Kunal Shah 2006-04-23 23:42:31 UTC
Created attachment 128134 [details]
out of of /sbin/lspci

output of lspci command for your reference.

thanks
kunal shah
kunalvshah@gmail.com

Comment 3 Martin Stransky 2006-04-25 06:31:24 UTC
Could you check to mute the "External Amplifier" switch? You may use alsamixer
command line utility, the 'M' key.

Comment 4 Kunal Shah 2006-04-27 00:48:03 UTC
Hi,
On your suggestion i did some googleing and did this

root@localhost ~]# amixer -c 0 sset "External Amplifier" unmute
Simple mixer control 'External Amplifier',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
[root@localhost ~]# alsactl store

After that i tried to play some music. no sound.
Then i tried to mute external amplifier. no sound.




Comment 5 Martin Stransky 2006-06-30 14:54:12 UTC
Please check new drivers, how-to is here-http://people.redhat.com/stransky/alsa/

Comment 6 Kunal Shah 2006-07-13 04:11:06 UTC
I am getting error following step 4
Configure and compile this package (do "$./configure" and "$make" in
alsa-driver-xxxx directory)

I am using alsa-driver-1.0.11.tar.bz2

for this "configure" went fine without erros but make gives compilation error.

  CC [M]  /sound/alsa-driver-1.0.11/pcmcia/pdaudiocf/pdaudiocf.o
In file included from /sound/alsa-driver-1.0.11/pcmcia/pdaudiocf/pdaudiocf.c:5:
/sound/alsa-driver-1.0.11/pcmcia/pdaudiocf/pdaudiocf_old.c: In function
âsnd_pdacf_freeâ:
/sound/alsa-driver-1.0.11/pcmcia/pdaudiocf/pdaudiocf_old.c:105: warning:
implicit declaration of function âpcmcia_deregister_clientâ
/sound/alsa-driver-1.0.11/pcmcia/pdaudiocf/pdaudiocf_old.c: In function
âsnd_pdacf_attachâ:
/sound/alsa-driver-1.0.11/pcmcia/pdaudiocf/pdaudiocf_old.c:207: warning:
implicit declaration of function âpcmcia_register_clientâ
/sound/alsa-driver-1.0.11/pcmcia/pdaudiocf/pdaudiocf_old.c: At top level:
/sound/alsa-driver-1.0.11/pcmcia/pdaudiocf/pdaudiocf_old.c:422: error: unknown
field âattachâ specified in initializer
/sound/alsa-driver-1.0.11/pcmcia/pdaudiocf/pdaudiocf_old.c:422: warning: excess
elements in struct initializer
/sound/alsa-driver-1.0.11/pcmcia/pdaudiocf/pdaudiocf_old.c:422: warning: (near
initialization for âpdacf_cs_driverâ)
/sound/alsa-driver-1.0.11/pcmcia/pdaudiocf/pdaudiocf_old.c:424: error: unknown
field âeventâ specified in initializer
/sound/alsa-driver-1.0.11/pcmcia/pdaudiocf/pdaudiocf_old.c:424: warning: excess
elements in struct initializer
/sound/alsa-driver-1.0.11/pcmcia/pdaudiocf/pdaudiocf_old.c:424: warning: (near
initialization for âpdacf_cs_driverâ)
/sound/alsa-driver-1.0.11/pcmcia/pdaudiocf/pdaudiocf_old.c:427: error: unknown
field âdetachâ specified in initializer
/sound/alsa-driver-1.0.11/pcmcia/pdaudiocf/pdaudiocf_old.c:428: warning: missing
braces around initializer
/sound/alsa-driver-1.0.11/pcmcia/pdaudiocf/pdaudiocf_old.c:428: warning: (near
initialization for âpdacf_cs_driver.drvâ)
/sound/alsa-driver-1.0.11/pcmcia/pdaudiocf/pdaudiocf_old.c:428: warning:
initialization from incompatible pointer type
make[5]: *** [/sound/alsa-driver-1.0.11/pcmcia/pdaudiocf/pdaudiocf.o] Error 1
make[4]: *** [/sound/alsa-driver-1.0.11/pcmcia/pdaudiocf] Error 2
make[3]: *** [/sound/alsa-driver-1.0.11/pcmcia] Error 2
make[2]: *** [_module_/sound/alsa-driver-1.0.11] Error 2
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.15-1.2054_FC5-i686'
make: *** [compile] Error 2


Comment 7 Kunal Shah 2006-07-16 02:36:11 UTC
I already have
alsa-lib-devel-1.0.11-4.rc2
alsa-lib-1.0.11-4.rc2
alsa-utils-1.0.11-4.rc2

Isnt this newer version than the one mentioned in your howto?

Thanks
Kunal

Comment 8 Martin Stransky 2006-08-08 11:16:03 UTC
I updated my page so there are fixed drivers for FC5 (1.0.12rc2)-
http://people.redhat.com/stransky/alsa/

Or you can check the latest kernel for FC5.

Comment 9 Kunal Shah 2006-08-09 01:10:39 UTC
I tried that and still not working with alsa-driver-1.0.12rc2.tar.bz2

For Fedora kernel its latest, i use 2.6.17-1.2139_FC5

Comment 10 Martin Stransky 2006-08-09 06:37:04 UTC
Please report your problem to ALSA upstream (www.alsa-project.org)