Bug 18997

Summary: findtr, mergetr and msg2qm are missed from QTDIR/bin - l10n of qt2 application impossible
Product: [Retired] Red Hat Linux Reporter: Leonid Kanter <leon>
Component: qtAssignee: Bernhard Rosenkraenzer <bero>
Status: CLOSED RAWHIDE QA Contact: Aaron Brown <abrown>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.0CC: abrown
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-10-15 14:29:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
patch for qt.spec none

Description Leonid Kanter 2000-10-12 20:32:18 UTC
findtr, mergetr and msg2qm are missed from QTDIR/bin. These binaries are
necessary to compile .po files. As a result, licq package (qt gui) from 7.0
doesn't have translations. The reason is in broken makefiles from qt-2.2.0.
Looks like makefile is fixed in 2.2.1. BTW, licq from RC1 included
translations and findtr, msg2qm were present in qt.

Comment 1 Bernhard Rosenkraenzer 2000-10-13 10:35:26 UTC
This is fixed in 2.2.1  (try rawhide or http://master.kde.org/~bero/rc2)


Comment 2 Leonid Kanter 2000-10-15 14:12:32 UTC
I was unable to find mergetr and msg2qm in qt-devel-2.2.1-3.i386.rpm from 
http://master.kde.org/~bero/rc2. They are still missed from qt makefiles, but
they are really necessary to build licq, for example. Look at my patch for
qt.spec.


Comment 3 Leonid Kanter 2000-10-15 14:29:31 UTC
Created attachment 4170 [details]
patch for qt.spec

Comment 4 Bernhard Rosenkraenzer 2000-10-16 16:27:52 UTC
It's fixed in 2.2.1-5. (I just closed the bug last time because you said Qt's
makefiles had been fixed in the base version).

Comment 5 openshift-github-bot 2018-03-22 23:30:29 UTC
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/f86911000584cdb2d916cf4233dca92ebea610b2
Merge pull request #19059 from wozniakjan/istio_logs/issue18997

Automatic merge from submit-queue.

Pick build container for logs with istio auto-inject - fixes #18997

When using istio auto-inject, the build pod is enhanced with a container sidecar - proxy https://github.com/openshift/origin/issues/18997

Given the build pod container name can change and istio appends its containers to the end of the container list, it should be possible to treat the first container in the pod's container list as the desired build container.

@openshift/sig-developer-experience any better suggestions? Do we want to stream the logs from all containers in builder pod instead?