Bug 19732

Summary: svgalib package is broken in 7.0
Product: [Retired] Red Hat Linux Reporter: Stan Bubrouski <stan>
Component: svgalibAssignee: Ngo Than <than>
Status: CLOSED RAWHIDE QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 7.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-10-26 13:10:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Stan Bubrouski 2000-10-25 01:43:31 UTC
Due to misconfigured compilation options the sgvalib package that comes
with 7.0 seems to be broken when compiling apps with svgalib support.  The
result of  the problem is that linking
of programs with -lvga included cause ld to exit complaining
/usr/lib/libvga.so.1 contains undefined references to __global_sti
__global_cli.

I noticed this trying to compile a couple things so I tried uninstalling
the svgalib and svgalib-devel packages and tried rebuilding from the source
RPM.  Building subsequently failed because ld was unable to find -lvga when
linking some stuff.  This tells me that if I had an older version of
svgalib installed it would use that to link the utils that come with
svgalib and could break a new install svgalib.  My assumption is that when
the svgalib packages that come with Red Hat 7.0 were built on a system
containing an older install of svgalib and this caused the package breakage
I am experiencing.  After applying the following patch I was able to
rebuild svgalib packages, install them, and the linking problem went away.

--- svgalib-1.4.1/utils/Makefile.stan   Tue Oct 24 20:55:46 2000
+++ svgalib-1.4.1/utils/Makefile        Tue Oct 24 20:59:54 2000
@@ -16,6 +16,9 @@
 CFLAGS = $(WARN) $(OPTIMIZE) -I../include
 #Use the next one for the Alpha/AXP if you need it
 #LDFLAGS = -L../staticlib 
+
+#This seems to be needed for linking when svgalib package is not already
installed.
+LDFLAGS = -L../sharedlib
 LIBS = -lvga -lm
 
 #----------------------------------------------------------------------

Comment 1 Ngo Than 2000-10-26 13:10:37 UTC
*** Bug 19733 has been marked as a duplicate of this bug. ***

Comment 2 Ngo Than 2000-10-26 14:05:05 UTC
It's fixed in svgalib-1.4.1-12.

Comment 3 Ngo Than 2000-10-30 09:20:37 UTC
*** Bug 19869 has been marked as a duplicate of this bug. ***

Comment 4 Need Real Name 2000-10-30 10:00:48 UTC
The updated svgalib-1.4.1-12 seems not to have reached rawhide.redhat.com.
As of 30-10-2000, only svgalib-1.4.1-11 can be reached there.

Comment 5 Stan Bubrouski 2000-11-06 06:50:17 UTC
Was fixed in an errata no in rawhide.  This should be changed to Resolution:
ERRATA as it is accurate whereas RAWHIDE is not.  The URL Of the updated
packages for 7.0 English is:

ftp://updates.redhat.com/powertools/7.0/i386/svgalib-1.4.1-12.i386.rpm
ftp://updates.redhat.com/powertools/7.0/i386/svgalib-devel-1.4.1-12.i386.rpm
ftp://updates.redhat.com/powertools/7.0/SRPMS/svgalib-1.4.1-12.src.rpm

-Stan Bubrouski