Bug 208573

Summary: NM applet doesn't show dialup connections as connected
Product: [Fedora] Fedora Reporter: Brian G. Anderson <bikehead>
Component: NetworkManagerAssignee: Christopher Aillon <caillon>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: mcepl, mcepl
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-02-15 23:39:47 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Brian G. Anderson 2006-09-29 14:04:10 UTC
Description of problem:
network manager applet doesn't show connection established after modem connects.


Version-Release number of selected component (if applicable):
NetworkManager-0.6.4-5.fc6


How reproducible:
Everytime


Steps to Reproduce:
1. Setup up a dialup modem connection using system-config-network
2. Restart NM and select the connection from the applet dialup-connections menu

  
Actual results:
Connection is established, but the not-connected icon is still displayed.  The
follow up result is that since the applet doesn't think there is any connection
it won't let me use the vpn selection menu in the applet.

Expected results:
the applet should show the connection as up.  I should also be able to choose a
vpn selection.

Additional info:
I use a bluetooth modem, but I have reproduced this using a pc-card modem also.
 The modem port is Modem0.  In the bluetooth modem case the hardware modem was
at /dev/rfcomm0.  In both cases, NM can bring the connection up and down, which
I confirmed using ifconfig ppp0.

Comment 1 Matěj Cepl 2007-02-15 23:39:47 UTC

*** This bug has been marked as a duplicate of 228404 ***