Bug 21828

Summary: Sawfish gives focus to the panel instead of a window when switching viewport
Product: [Retired] Red Hat Linux Reporter: vigna
Component: sawfishAssignee: Havoc Pennington <hp>
Status: CLOSED WONTFIX QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-12-07 01:59:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description vigna 2000-12-06 21:28:53 UTC
This behaviour is erratic, and very difficult to reproduce, but fairly
regular. If you have a single workspace and several viewports (I have 2x4
viewports) and exactly one window in each viewport, when switching
viewports sawfish starts to select the gnome panel instead of the only
present window. The result is that often you do something with applets that
you do not really want (such as stopping a ppp connection by pressing
RETURN). I have tried every possible focus selection combination, but this
really seems to be a problem of sawfish not noticing that it should not
give focus to the panel when switching viewports if there is another
window.

Comment 2 vigna 2000-12-06 23:02:58 UTC
I have tried, but the problem is still there. It appears to happen more often
when you switch from a viewport containing a big app like Netscape to a viewport
containing a gnome-terminal rather than the opposite, but again since it is
rather impredicible this could be a red herring...

I forgot to mention that the problem appears both switching between viewports
with keys and switching between viewports with the mouse.

Comment 3 Havoc Pennington 2000-12-07 01:59:17 UTC
John Harper (sawfish author) says he thought he fixed it, and requested your
~/.sawfish/custom file so he can try to reproduce it with your exact setup. Can
you maybe send that to jsh@eazel.com? Thanks!

Comment 4 Havoc Pennington 2001-07-12 18:06:48 UTC
Forwarded upstream as http://bugzilla.eazel.com/show_bug.cgi?id=8411

Closing here.