Bug 228928

Summary: oddjob: $RPM_OPT_FLAGS not used
Product: [Fedora] Fedora Reporter: Ville Skyttä <ville.skytta>
Component: oddjobAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-09-06 00:09:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Ville Skyttä 2007-02-15 21:57:06 UTC
http://www.redhat.com/archives/fedora-maintainers/2007-January/msg00339.html

There's something odd (pun intended :)) going on here, none of my usual suspects
apply, but the result is that CFLAGS from the environment is not used during
build, even though %configure sets it.  It gets lost somewhere.

A bit off topic, but %configuring with --disable-dependency-tracking would make
the build output cleaner and easier to notice problems like this, and could
provide a slight build speedup.

Comment 1 Nalin Dahyabhai 2007-02-15 23:39:51 UTC
Ugh, this isn't a packaging bug.  I'll have to roll a new release to fix it.

Comment 2 Ville Skyttä 2007-07-28 20:10:05 UTC
Any news?

Comment 3 Nalin Dahyabhai 2007-09-05 21:16:50 UTC
Should be fixed in 0.29.