Bug 230300

Summary: autofs in RHEL 3 Update 8 fail to check the NIS automount map
Product: Red Hat Enterprise Linux 3 Reporter: Wesly Chen <wesly.chen>
Component: autofsAssignee: Jeff Moyer <jmoyer>
Status: CLOSED DUPLICATE QA Contact: Brock Organ <borgan>
Severity: high Docs Contact:
Priority: medium    
Version: 3.8CC: ikent
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-03-05 18:06:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Wesly Chen 2007-02-28 02:49:27 UTC
Description of problem:
 My Redhat Enterprise Linux WS 3.0 Update 7 upgraded to Update 8, then my 
autofs failed.
It seems to me that the vsion of autofs on update 8. autofs-4.1.3-186, cause 
the problem.
So all my NIS automount maps fail.

   When I start the autofs (# service autofs restart), it shows "Not 
Mountpoints Defined" even though there are a lot of mount points defined in 
NIS. Unless I put those mount points into /etc/auto_<map files>.

   Temporarily work around is roll back the autofs to autofs-4.1.3-168 which 
comes with Update 7.


Version-Release number of selected component (if applicable):
autofs-4.1.3-186

How reproducible:


Steps to Reproduce:
1. install autofs-4.1.3-186
2. create NIS map auto_master with "/home  auto_home" in it
3. Create NIS map auto_home with "user1  <NFS_server>:/users/user1"
4. Make sure <NFS_server>:/users/user1 is shared out on NFS
5. echo "+auto_master" > /etc/auto.master
6. /etc/rc.d/init.d/autofs start
  
Actual results:
# /etc/init.d/autofs start
Starting automount: No Mountpoints Defined    [  OK  ]

Expected results:
# /etc/init.d/autofs start
Starting automount:        [  OK  ]

Additional info:
1.
$ grep -v ^# /etc/sysconfig/autofs
LOCALOPTIONS=""
DAEMONOPTIONS="--timeout=60"
LDAPAUTOMASTER=""
UNDERSCORETODOT=1
DISABLE_DIRECT=1
ONE_AUTO_MASTER=0
GHOSTDIRS=""
BASEDN=

2.
$ grep automount /etc/nsswitch.conf
automount:  files nis

3. 
$ grep -v ^# /etc/auto.master
+auto_master

4. 
$ ypcat -k auto_master
/user auto_home

5.
$ ypcat -k auto_home
*  <NFS server name>:/vol/fvol1/users/&

6.
$ uname -r
2.4.21-47.0.1.ELsmp

7. 
$cat /etc/redhat-release 
Red Hat Enterprise Linux WS release 3 (Taroon Update 8)

Comment 1 Jeff Moyer 2007-03-05 18:06:28 UTC

*** This bug has been marked as a duplicate of 230304 ***