Bug 231733 (CVE-2007-1267)

Summary: CVE-2007-1267: sylpheed <= 2.2.7 message forgery vulnerability
Product: [Fedora] Fedora Reporter: Ville Skyttä <ville.skytta>
Component: sylpheedAssignee: Michael Schwendt <bugs.michael>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 6CC: fedora-security-list
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-03-10 23:27:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Ville Skyttä 2007-03-10 22:19:40 UTC
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2007-1267

"Sylpheed 2.2.7 and earlier does not properly use the --status-fd argument when
invoking GnuPG, which prevents Sylpheed from visually distinguishing between
signed and unsigned portions of OpenPGP messages with multiple components, which
allows remote attackers to forge the contents of a message without detection."

This issue is reported against a suspiciously old version of Sylpheed; bug filed
for verification whether current versions in FE5+ are affected.

Comment 1 Michael Schwendt 2007-03-10 23:27:48 UTC
Sylpheed uses GPGME, and GPGME 1.1.4 in FE6+ fixes the vulnerability:
http://lists.gnupg.org/pipermail/gnupg-announce/2007q1/000251.html

FE5 includes a patched version of GPGME 1.1.2
(gpgme-1.1.3-multiple-message.patch).