Bug 232568

Summary: can't set breakpoints on lines in other than first template instance
Product: Red Hat Enterprise Linux 4 Reporter: starlight
Component: gdbAssignee: Jan Kratochvil <jan.kratochvil>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4.4CC: cagney
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-03-16 15:01:47 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 232653    

Description starlight 2007-03-16 04:59:04 UTC
It is impossible to set breakpoints on lines in the 2-n 
instances of templates.  The 'rbreak template<.*>::function' 
approach only goes so far.  At one time it was possible to set a 
breakpoint on a line in a template function once the initial 
'rbreak' was hit and the context was current, but this doesn't 
work as of 'gdb-'.  Tried vanilla 'gdb' 6.6 
with same result.

'gdb' site bug report on this seems to be years old and have 
received no attention whatsoever:


This problem is truly maddening!  Makes 'gdb' useless! Have to 
do most debugging on Solaris and Windows because of it.

Comment 1 Jan Kratochvil 2007-03-16 09:08:43 UTC
Confirming it is a known bug.
There is even now syntax to specify the instance without changing the context.
Changing the context usually works but it did not work for me even on RawHide
during a test now.
I am sorry that I have to advice you to submit your request through your RHEL
customer support contract for better support priority.

Comment 2 starlight 2007-03-16 09:46:07 UTC
What is the explicit syntax?  Which version(s) of 'gdb' have it?

Comment 3 Jan Kratochvil 2007-03-16 11:14:50 UTC
I am very sorry as it was typo "even now syntax" -> "even no syntax".

Comment 4 Andrew Cagney 2007-03-16 14:52:04 UTC
Upstream bug.

Comment 5 RHEL Product and Program Management 2007-03-16 15:01:47 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 

Comment 6 starlight 2007-03-16 18:28:35 UTC
It seems like a serious bug.  Why not keep it open, even though 
it requires a fix from upstream.  Does RH not have some 
influence with upstream developers?

BTW found that the Intel compiler 'idb' and 'idbe' debuggers 
will set a breakpoint for every template instance.  Mentioning 
this for anyone else that might find this bug report.  ICC/IDB 
is available for free for non-commercial use.

Comment 7 Jan Kratochvil 2007-03-16 18:40:16 UTC
Upstream already tracks this Bug as you mentioned in Comment 0.
Red Hat management decided this Bug is not important enough on the priority
lists as Red Hat pushes its analysis tool frysk (package "frysk") instead:
Unfortunately frysk is still not enterprise ready but any feedback or even
contributions are appreciated.

Comment 8 Andrew Cagney 2007-03-16 19:11:05 UTC
Frysk is available on RHEL 4 as a technology preview; it continues to be
updated.  All the tools necessary to build frysk are also made available.

In RHEL 5.0, frysk's basic utilities - fstack, ftrace et.al. - are supported
while the gnome and command-line interfaces remain tech-preview.

Comment 9 starlight 2007-03-16 22:36:12 UTC
Sorry but I don't need Xen just yet and have a lot of work 
that's more important than playing with RHEL 5, so I'm sticking 
with versoin 4.  Need to debug today, not tomorrow, so I think 
'idb' will do just fine.  I prefer command-line debugging 

I see that RH Bugzilla is morphing into a sales channel of late. 
Won't bother posting any more bugs here.  Don't have big company 
idiot indemnification and idiot support requirements, so we use 
free free software here, as opposed to the expensive free 
software that RH sells.  From what I've seen, paying for support 
doesn't get you much.