Bug 234839

Summary: Add a virsh "core-dump" command
Product: Red Hat Enterprise Linux 5 Reporter: Chris Lalancette <clalance>
Component: libvirtAssignee: Daniel Veillard <veillard>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.0CC: berrange
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-04-02 20:45:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Chris Lalancette 2007-04-02 14:53:13 UTC
Description of problem:
It would be very helpful if libvirt, and virsh, supported a core-dump command
similar to xm.  For instance, you can run:

xm dump-core -C <dom>

to crash a domain and drop the core in /var/lib/xen/dump; virsh should be able
to do the same.  I believe that this is generally useful for virtualization,
even if only Xen currently has this capability.

Comment 2 Daniel Berrangé 2007-04-02 20:45:40 UTC
Turns out this capability is already in GA:

# rpm -q libvirt
libvirt-0.1.8-15.el5


# virsh list
 Id Name                 State
----------------------------------
  0 Domain-0             running
  3 demo                 blocked

# virsh dump demo /var/lib/xen/dump/demo.img
Domain demo dumpd to /var/lib/xen/dump/demo.img